Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
57 Views

webrtc 3.3 , Login error

Hello, i am using version 3.3, centos 7.2
Follow the steps to install the server, start the server,
In version 53 of the Google browser enter https://192.168.1.186:3004
The following error occurred:

ERROR: server connection failed: Participant Ff3IvYdDREhb5Hl4AAAA join session 58a397f889d0146a63476ec6 failed

 

Test a lot of times or so, then re-install the server, or the above errors,

Ask for help, thanks!

Tags (2)
0 Kudos
21 Replies
Highlighted
Beginner
57 Views

Did anyone encounter this problem? Help me, thank you.

0 Kudos
Highlighted
Employee
57 Views

Have you started the MCU correctly without error log? Can you zip your log folder and paste here or send us through webrtc_support@intel.com?

0 Kudos
Highlighted
Beginner
57 Views

Lei Zhai (Intel) wrote:

Have you started the MCU correctly without error log? Can you zip your log folder and paste here or send us through webrtc_support@intel.com?

I sent it to your mailbox, please check it out    

0 Kudos
Highlighted
Beginner
57 Views

0 Kudos
Highlighted
Employee
57 Views

Video work node start fail. Can you check whether you have './videoMixer_sw/build/Release/videoMixer-sw' fold and a xxx.node file under it. Also the user you run start_all.sh has proper execution permission on it.

2017-05-18 03:04:36.496  - ERROR: VideoNode - { [Error: Cannot find module './videoMixer_sw/build/Release/videoMixer-sw'] code: 'MODULE_NOT_FOUND' }
Error: Cannot find module './videoMixer_sw/build/Release/videoMixer-sw'
    at Function.Module._resolveFilename (module.js:337:15)
    at Function.Module._load (module.js:287:25)
    at module.exports (woogeen/video/index.js:88:33)
    at _third_party_main.js:116:56
    at /home/sct/3.3/Release-v3.3/video_agent/amqp_client.js:1:5275
    at /home/sct/3.3/Release-v3.3/video_agent/amqp_client.js:1:1272
    at Queue._onMethod (/home/sct/3.3/Release-v3.3/video_agent/node_modules/amqp/lib/queue.js:466:9)
    at Queue.Channel._onChannelMethod (/home/sct/3.3/Release-v3.3/video_agent/node_modules/amqp/lib/channel.js:85:12)
    at Connection._onMethod (/home/sct/3.3/Release-v3.3/video_agent/node_modules/amqp/lib/connection.js:454:28)
    at AMQPParser.self.parser.onMethod (/home/sct/3.3/Release-v3.3/video_agent/node_modules/amqp/lib/connection.js:136:12)

0 Kudos
Highlighted
Beginner
57 Views

I have this file.

This problem is solved, I found that the first implementation. / Init-all - deps, and then implement. /start-all.sh, the above problems will not occur,
But there was a new problem...
Console
ERROR: create LocalStream failed: Object {code: 1104, msg: "Not all device requests are satisfied."}

As shown below:

This is a log file  550846

I used the 3.1 version of the time, the use of the same camera, did not appear this problem, what is the reason for this error? Thank you!

0 Kudos
Highlighted
Employee
57 Views

Seems your local device not ready, check the error flag in upper corner of Chrome.

0 Kudos
Highlighted
Beginner
57 Views

I was not a microphone, I modified script2.js in the

Woogeen.LocalStream.create ({
               video: {
                 device: 'camera',
                 resolution: myResolution
               },
               audio: false
             }
It's up.
But I found 3.1 before the version, even if there is no microphone, audio is true, it will not have this problem ah, which is why?

 

All in all, thank you for your help.

0 Kudos
Highlighted
Employee
57 Views

Yes, we changed the local media creation behavior after v3.1. After changing we will exactly follow customer specified parameters. If not match, report error.

0 Kudos
Highlighted
Beginner
57 Views

Screenshot from 2017-06-02 13-02-19.png

0 Kudos
Highlighted
Beginner
57 Views

I am having the same issue . Please help me out.

Thank you!!

0 Kudos
Highlighted
Beginner
57 Views

Screenshot from 2017-06-02 13-06-37.png

0 Kudos
Highlighted
Beginner
57 Views

Screenshot from 2017-06-02 13-06-48.png

0 Kudos
Highlighted
Beginner
57 Views

node: ./lib/libstdc++.so.6: version `GLIBCXX_3.4.21' not found (required by node)
node: ./lib/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by node)

 

0 Kudos
Highlighted
Employee
57 Views

@Mansi, make sure your Ubuntu version is LTS14.04 64bit with its default c++ library.

0 Kudos
Highlighted
Beginner
57 Views

Lei Zhai (Intel) wrote:

@Mansi, make sure your Ubuntu version is LTS14.04 64bit with its default c++ library.

@Lei I am using ubuntu LTS16.04.

Is there any problem with that:(

Reply asap.

0 Kudos
Highlighted
Employee
57 Views

We only tested with 14.04, 16.04 should not work especially with different version C++ library.

0 Kudos
Highlighted
Beginner
57 Views

Lei Zhai (Intel) wrote:

We only tested with 14.04, 16.04 should not work especially with different version C++ library.

Is there any way to import that particular library??

0 Kudos
Highlighted
Beginner
57 Views

Screenshot from 2017-06-06 13-09-14.pngI was able to import the library but for createToken i am getting status code 401 unauthorisedScreenshot from 2017-06-05 12-27-09.pngI was able to import the required library but now I am getting the error 503(SERVICE UNAVAILABLE).

Please reply asap.

0 Kudos