Intel® Compute Stick
Support for Intel® Compute Sticks and Cards
536 Discussions

Bricked Compute Stick STCK1A32WFC


Wonder whether anyone can help

I have an Intel Compute Stick, STCK1A32WFC, running windows 10 (I think it came with windows 10, or maybe it updated itself)

It worked fine for a couple of years, and then stopped working. I don’t think it was updating itself at the time, but with windows 10 you never know

I’ve put the full symptoms below. Just to be clear, I’m not asking anyone to provide me with instructions on how to restore the O/S or links to tell me how or links to download new BIOS’s or O/S’s.  I have all those already

So symptoms are the device powers up, shows a steady blue light. Draws current (initially around 0.8A, then after a 10 seconds reduces down to around 0.4A over the next 10 seconds). However it does not display anything at all on the HDMI port, nor does it boot. It does get warm, but the fan never moves. The fan isn’t stuck though. It does not have a SD card in it, but it makes no difference if it does.

There is a signal of some kind coming from the HDMI port as on the monitor I’m using it detects this as it allows the HDMI source to be selected if the stick is plugged in. The monitor does not, for example, do this with just a HDMI cable plugged in

It is not booting as it did before and just not displaying. It was set to boot, connect to a network, and then allow remote login to it. It does not attempt to connect t the network

It is not the power supply, the power supply is well capable of providing enough power, always worked before, and I’ve tried several different power supplies

It is not the Monitor. The monitor works perfectly well with other HDMI devices, is one that always worked fine with this Compute Stick, and I’ve tried several different monitors

It is not the HDMI cable, I’m not using one, I’m plugging straight into the monitor

But I have also tried it with a cable just in case. The stick always used to work fine with or without a HDMI cable

I’ve tried plugging a keyboard in (a known one, that always used to work fine on this compute stick, and tried this both with a powered USB hub and without) and pressing F2, F7 to get into setup. But this makes no difference, there is still nothing displayed on the monitor

I’ve tried the power button menu (hold the power button down for 3 seconds and release before the device powers off), and still get nothing on the display

Most of the time I’d say this is hardware failure, but the fact that some kind of HDMI signal is present, and the initial 0.8A current that then reduces, suggests that the hardware is working, but somehow it is getting stuck on loading the initial bios. Also hardware failures are rare, much rarer than software failures.

Intel won’t offer support as the product is discontinued, and of course it is well out of warranty

On most boards there is a jumper setting that would allow problems like this to be resolved.

Does anyone have any suggestions as to what to try next?

Or failing that are there any places that repair these sticks that anyone knows of (I’m in the UK).

Or are there any other forums where these sticks are discussed, perhaps more hardware/repair orientated ones that I could try and find help. 

Or do I just accept it is broken and move on


Any help greatly appreciated. If I do get it fixed I’ll post up what worked in case that helps anyone else


Many thanks

0 Kudos
9 Replies

Hello nb7,

Thank you for posting on the Intel* Community. 

Unfortunately, as you mentioned, due to this product being discontinued, Intel Customer Service no longer supports inquiries for it, but perhaps fellow community members have the knowledge to jump in and help so we will keep your thread open. You may also find the Discontinued Products website helpful to address your request. 

Please keep in mind that this thread will no longer be monitored by Intel. Thank you for your understanding.


Best regards,

Maria R.

Intel Customer Support Technician

Super User Retired Employee

One of my FC Compute Sticks has acted this way a couple of times. What I did was the following:

  1. Disconnect power and HDMI. Wait 30 seconds.
  2. Reconnect and power on. Wait 30 seconds.
  3. Hold the power button in until you see the LED turn off. Wait 30 seconds.
  4. Power on.

That's it, the unit then booted properly.

Hope this helps,



Thank-you for your suggestion. I had already tried that. It doesn't work

Super User Retired Employee

I can't remember if the Compute Sticks support the Power Button Menu, but let's give this a try. Power off and then power on, holding the power button in for exactly 3 seconds. If the LED goes back off, you held the button in for slightly too long. If the PBM is supported, after some number of seconds (max 30 on these Atom processors),  the menu will appear. From there, you can try to reset the state of the BIOS.

Hope this helps,



Thank-you for your suggestion. I had tried that already, and have tried again just now. It doesn't work

Super User Retired Employee

Hhmmm, only thing left the I can think of is clearing CMOS. It is a pain in the a$$ opening the case to unplug the battery for 10 minutes but it can be done (carefully!).



Thank-you for your suggestion. Will try that and report back. Is there anywhere online that will give the exact battery spec, other resources suggest it is  a non-rechargeable CR1220W but with a specific intel connector as per this picture here. But it would be nice to know for certain and to have one available to replace before opening up the case.

Super User Retired Employee
I can get that info, but not before tomorrow (Monday). I wasn't suggesting that the battery was dead, only that we need to unplug it (for 10 mins) to clear CMOS.

OK tried that. It was a little easier to get to than I expected

The battery is (very) dead. As in 7mV across it when disconnected, dropping to 4mV after a minute or so.

No luck with the waiting 10 minutes to see if the CMOS clears or resets itself either. The stick behaves exactly the same as described above without the battery plugged in.

The next step would be to get 3V to the CMOS somehow, but given how long it would take to get a replacement battery (6 weeks) or to rig one up (not easy given the size of those connectors) it is worth asking the following

Does anyone know (or have experience of) running these sticks without a battery. Do they (as many boards do) quite happily run without a cmos battery, but without being able to keep correct time or save any BIOS settings. Or do they require a voltage from the battery to work at all