Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MWall9
Beginner
2,026 Views

Compute Stick STCK1A8LFC - Headless

Hi, I'm trying to book the Ultra-Slim Computer STCK1A8LFC with no display head on it. I've managed to edit the /etc/default/grub file as suggested and it now boots in console mode but does not boot without a display attached.

at the moment I have

GRUB_DEFAULT=0

GRUB_HIDDEN_TIMEOUT_QUIET=TRUE

GRUB_TIMEOUT=2

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

GRUB_CMDLINE_LINUX_DEFAULT=""

GRUB_CMDLINE_LINUX="locale=en-GB,UTF-8"

GRUB_RECORDFAIL_TIMEOUT=5

and everything else is commented out.

Does anyone have any suggestion how to make it boot without the display? Is it possible?

Many thanks

Martin

0 Kudos
18 Replies
linuxium
New Contributor III
190 Views

To boot Ubuntu in text mode rather than with a GUI you only need to change GRUB's configuration file. Edit the file '/etc/default/grub' and change the line that starts 'GRUB_CMDLINE_LINUX_DEFAULT=' to 'GRUB_CMDLINE_LINUX_DEFAULT="quiet text". As you will be booting effectively as a headless server then it also makes sense to change any timeouts to zero. Therefore set both 'GRUB_HIDDEN_TIMEOUT=' and 'GRUB_TIMEOUT=' to '0'. Additionally set the default boot option to match the appropriate menu option noting that zero represents the first selection. You modified file should then look similar in part to:

GRUB_DEFAULT=0

GRUB_HIDDEN_TIMEOUT=0

GRUB_TIMEOUT=0

GRUB_CMDLINE_LINUX_DEFAULT="quiet text"

Finally as root run the command 'update-grub2' to effect the changes.

And if having logged in on the console you find you want to start your default GUI, then simply run 'service lightdm start' as root.

MWall9
Beginner
190 Views

Hi, Many thanks for getting back to me. That was the first thing I tried. It takes me directly to a login prompt when the stick is plugged into a monitor but when I shut it down, remove it from the monitor and reboot it it seems to get no where. How do I know it's got no where? I have a share that I can see from my Windows PC. Plugged into a monitor it boots to the login prompt and I can see my share. Not plugged into a monitor then my share never appears.

I think more magic is required!

Martin

MWill30
Beginner
190 Views

After some trying I have the stick running headless. I installed Ubuntu desktop, then installed Ian's script for the wifi drivers. To load headless I had to pass nomodeset to the kernal. Here's my grub setting::

GRUB_DEFAULT=0

GRUB_HIDDEN_TIMEOUT=4

GRUB_HIDDEN_TIMEOUT_QUIET=true

GRUB_TIMEOUT=4

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

# GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_CMDLINE_LINUX="nomodeset"

GRUB_RECORDFAIL_TIMEOUT=$GRUB_TIMEOUT

MWall9
Beginner
190 Views

Hi Ecoeco,

Many thanks for adding a reply to the post. Can you be more specific about the "script for the wifi drivers' please? Where do I find that?

Many thanks

Martin

MWill30
Beginner
190 Views

Hi Martin

This took quite a bit of experimenting and troubleshooting over the past couple of days. At the moment my stick will boot headless (tested with the TV turned off). I'm using the stick as a file server and Domoticz home automation server so I've removed most of the desktop packages and am running ubuntu server on the machine.

My process so far has been:

Extra Hardware:

USB to ethernet adapter (I haven't tried with wifi yet) - I use this one: http://www.amazon.com/Belkin-USB-Ethernet-Adapter-F4U047bt/dp/B00E9655LU Amazon.com: Belkin USB 2.0 Ethernet Adapter (F4U047bt): Electronics

USB hub to connect the ethernet and keyboard to the device at the same time

1. install Ubuntu 14.04.2 desktop using linuxium's instructions in this post:

/message/318033# 318033 Unofficial "official" Ubuntu for the STCK1A32WFC (Windows)

I am using the whole drive for Ubuntu and so removed Windows and the recovery partition.

I had to use this desktop Ubuntu image as the server image wouldn't detect the onboard SSD drive.

This post includes the link to linuxium's script to install the wifi, bluetooth etc drivers for the machine.

2. Turn the desktop system into a server - to avoid any issues when Ubuntu wants to load lightDM. I suppose you could just disable lightDM if you wanted.

sudo apt-get install tasksel 

sudo tasksel remove ubuntu-desktop

 

sudo tasksel install server

 

sudo apt-get update

 

sudo apt-get install linux-server linux-image-server

 

sudo apt-get purge lightdm

Install SSH:

sudo apt-get install openssh-server

3. update grub with the following settings:

GRUB_DEFAULT=0

GRUB_HIDDEN_TIMEOUT=4

GRUB_HIDDEN_TIMEOUT_QUIET=true

GRUB_TIMEOUT=4

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

# GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

GRUB_CMDLINE_LINUX="nomodeset"

GRUB_RECORDFAIL_TIMEOUT=$GRUB_TIMEOUT

GRUB_TERMINAL=console

4. do a:

sudo update-grub

Reboot and the system responds over ethernet and you can ssh in to the box.

When I find some time I'll test this with the wifi network device to see if this comes up cleanly. I'll also test this with the device physically removed from the TV (not just powered off) but in theory it should work fine.

 

My biggest problem was identifying the need to pass nomodeset to the kernel. the device kept rebooting with an error saying no video mode was set. nomodeset tells the kernel not to try to set a video mode.

 

Hope this helps - let me know if you find a better way to do this set up.

 

MWall9
Beginner
190 Views

Hi Ecoeco,

Many thanks for the complete answer. I'm working on a different project for the next few days but I will certainly be giving it a try ...

I'll let you know how I get on!

Many thanks

Martin

MWall9
Beginner
190 Views

Hi Ecoeco,

Well I've been playing with this all day so far and does as suggested above does get me to the point of seeing a login prompt and I can ssh to the machine but only when plugged into a monitor. If I boot without a monitor it seems to fail - or at least I can't ssh to it as ssh reports a network error. If I then plug it back into the monitor I get "invalid video mode specification 'text'. Booting in blind mode. At this point I can ssh but it's not clean. It I then, while plugged into the monitor, turn it off and back on again it boots cleanly.

This stick I'm using is a pure Ubuntu stick not a Windows stick - not sure if this makes any difference or not!

Martin

bdole1
Beginner
190 Views

Thank you for the thorough instructions Ecoeco! Unfortunately, just like G0PJO i'm also unable to boot headless with the ubuntu version of the compute stick. Very strange and disappointing!

bdole1
Beginner
190 Views

Well, I went ahead and returned the Ubuntu intel stick and picked up the windows version hoping it would make a difference. After formatting it and following Ecoeco's instructions exactly it still refuses to boot when not plugged into a monitor. I'm thoroughly confused...

MSaud
Novice
190 Views

Thank you all for your information as well.

Before discovering this thread I also responded to another thread here:

I have the 32GB windows stick with Ubuntu 14.04.3 installed on it right now, and have tried a number of variations of this set of instructions, (see the previous link for a better description of current attempts), as well as a few others that resulted in reinstalling Ubuntu and have not been able to get the stick to boot when not connected to an hdmi monitor.

I posted a link to this thread at the one I first responded to and am hoping that someone discovers a solution and can enlighten us all. Thanks for all of the breadcrumbs... the answer still eludes me.

-Mark

linuxium
New Contributor III
190 Views

I've written a script to allow you to boot headless without anything connected to the HDMI. This works on my Windows ICS device running my Ubuntu 14.04.3 LTS ISO installed to eMMC.

To boot headless download my patch from https://drive.google.com/file/d/0B99O3A0dDe67TGZjQWtZTVRMNDA/view?usp=sharing linuxium-headless-patch.sh - Google Drive and make the script executable by entering 'sudo chmod 700 linuxium-headless-patch.sh' and then run the script by entering 'sudo ./linuxium-headless-patch.sh'.

Basically the script will take how you are currently booted and create a new GRUB configuration file to boot equivalently without graphics that then allows you to boot both with and without a monitor/display device connected to the HDMI port of the ICS.

With a monitor connected pressing Ctrl-Alt-F1 will provide a text-based login screen. Booting without a monitor obviously requires remote access to have been previously set up so as a minimum I suggest installing ssh (enter 'sudo apt-get -y ssh openssh-server' and access remotely with 'ssh '). If you accidentally lock yourself out modifying GRUB during subsequent editing/experimenting then use my ISO on a USB to regain control.

MMita1
Beginner
190 Views

My ICS (Ubuntu) dose not boot without HDMI, too.

When power on ICS without HDMI, ICS is not working. but power LED is on.

When plug to HDMI after power on, nothing to display.

I tried linuxium's script, but it is not resolved.

linuxium
New Contributor III
190 Views

How have you configured your network connection? Given you are booting in 'text' mode make sure your network is configured in '/etc/network/interfaces' or look at configuring 'network-manager' to start automatically.

LHill_Intel
Moderator
190 Views

Hi all,

Please give the new BIOS at https://downloadcenter.intel.com/download/25506 Download BIOS Update [FCBYT10H.86A] a try. This one includes a fix for headless issues in Linux.

Regards,

Lois

Intel

Ricardo_G_Intel1
Employee
190 Views

Please let us know how it goes.

ysasa2
Beginner
190 Views

Hi all,

I had same trouble. And updated BIOS to FCBYT10H.86A.

After update, got message like "no bootable image found ...".

(while updating, the usb hdd that installed Ubuntu was unplugged)

So, I reinstalled(clean installed) Ubuntu. and now it's running headless correctly.

I'm using STCK1A32WFC and Ubuntu Server 14.04.

I hadn't edit /etc/default/grub after reinstall.

EstebanA_C_Intel
Employee
190 Views

Hello, y.sasaki:

Thank you for providing the outcome on this situation and how it was solved.

Regards,

Esteban C

Ronny_G_Intel
Moderator
190 Views

Hello All,

I am sorry to hear that you are having issues with this integration. Intel is currently investigating this issue and we will keep this community thread updated. There is also another post referring to the same issue, see it here: . I will update both posts as soon as I get any news.

Regards,

 

Reply