Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
2,223 Views

Compute Stick (STK1A32WFC) goes to sleep when left on.

I am trying to use my compute stick at a very basic level - as a low power iTunes server. Left on all the time with a single iTunes library based on an NAS device. I previously had it set up on a laptop, but obviously that uses more power. The compute stick pretty much worked out of the box, installed iTunes, moved the library over and everything was fine - providing content via Home Sharing in iTunes. However, after a while the compute stick seems to go to sleep - no connection or output until I press the on/off button and then it wakes up. The power settings are "always on" - what am I missing - where is the setting that is making this happen?

Tags (1)
0 Kudos
8 Replies
Highlighted
Employee
30 Views

Hi AndyL63,

 

Please change the power options, set "turn off the display" and "Put the computer to sleep" to never, then save changes.

Check the following:

 

 

 

Regards,

Hellen.

 

0 Kudos
Highlighted
Beginner
30 Views

Thanks Helen, unfortunately those settings are already set to stay on all the time. I am currently investigating the following fix:

/message/349228 Compute Stick Sleep/Hibernate when TV is turned off

This changes a value in the registry and indicates my problem is linked to the fact that the compute stick is not connected to a monitor when the html lead appears to be not connected - i.e. the TV is off.

0 Kudos
Highlighted
Employee
30 Views

Hi AndyL63,

 

Could you please tell me the model of your TV?

 

Some TVs set automatically in sleep mode; this could be a possibility in this case. Please check your TV's sleep settings, this can also affect the behavior of the Intel® Compute Stick.

 

You can also check the Tested Peripherals for Intel® Compute Stick STCK1A32WFC and STCK1A8LFC

http://www.intel.com/content/www/us/en/support/boards-and-kits/intel-compute-stick/000006029.html http://www.intel.com/content/www/us/en/support/boards-and-kits/intel-compute-stick/000006029.html

 

Regards,

Hellen.

0 Kudos
Highlighted
Moderator
30 Views

Hi AndyL63,

Let me tell you that the BIOS for this particular model supports the following power state options:

This information is available here: https://downloadmirror.intel.com/24986/eng/STCK1A32WFC-STCK1A32FC-STCK1A8LFC-TechProdSpec01.pdf https://downloadmirror.intel.com/24986/eng/STCK1A32WFC-STCK1A32FC-STCK1A8LFC-TechProdSpec01.pdf page # 13, table 1.11.1.1.

On the other side, it is very possible that the Operating System is taking care of the power management, please see the following recommendation below, keep in mind that this suggestion is Windows Generic, you may need to look for the options that apply to your device and settings.

1- Open the advanced options in Windows by holding the Windows key on your keyboard and the letter X. Select the RUN option.

2- Type GPEDIT.MSC and click OK.

3- In the Local Group Policy Editor, go to Computer Configuration > Administrative Templates > System > Power Management > Sleep settings.

4- In sleep settings find the Allow applications to prevent automatic sleep.

5- Now click the Enabled button, then click Apply and OK.

6- Now find the Turn on the ability for applications to prevent sleep transition field, go to Edit policy setting, then select Enabled and then Apply and OK.

7- Close the group policy editor, hold down the Windows key and the letter X as we did in the beginning and open Run. Then type REGEDIT into the run field and click OK.

8- Once in the registry editor we need to navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power.

9- Inside the power folder click on HibernatedEnabled to edit the field. Change the value from 1 to 0 and click OK. Do the same for the HiberfileSizePercent field as well.

0 Kudos
Highlighted
Beginner
30 Views

Thanks, I will try this as soon as I get back fro travelling.

0 Kudos
Highlighted
Employee
30 Views

Hi,

 

Thanks Rguevara, AndyL63 please let us know if it works.

 

Regards,

Hellen.

 

0 Kudos
Highlighted
Beginner
30 Views

Apologies for the long silence.

This fix works perfectly for me - the stick has been on for over a week and has remained on with no issues.

Thanks

0 Kudos
Highlighted
Employee
30 Views

Hi AndyL63,

Great to know that this helps your solved your issue.

Regards,

Hellen.

0 Kudos