Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,568 Views

Compute Stick m3- very slow Splash

I have just got a STK2M364CC with which I have installed win10 64bit, all the latest drivers and the latest bios. Everything runs smoothly when I am in win10 however every time I start the machine it hangs on the very first intel compute screen (before the F2 bios options appear) for 17-22 seconds which seems abnormally long, once the F2 bios options appear it seems to open windows in another 20ish seconds which feels about correct.

Has anyone else had this?

Is it correct?

If not anyone got any ideas how to fix it?

I have tried a repair of Win10, droping the bios back to a few older versions, turning off all the other boot options in the bios. None had any effect

0 Kudos
7 Replies
Highlighted
Super User Retired Employee
46 Views

What else do you have plugged into the ICS? Does this only occur on power-on or does it happen during restarts too?

...S

P.S. There is a facetious answer: Who cares? You should only rarely be going through the boot process. [Sorry, had to say it ]

0 Kudos
Highlighted
Beginner
46 Views

It does it on both restart and power on, with or without keyboard/mouse plugged in and no memory memory card.

"P.S. There is a facetious answer: Who cares? You should only rarely be going through the boot process. [Sorry, had to say it ]"

I do agree but its really irritating me and my weird tech OCD...

0 Kudos
Highlighted
Super User Retired Employee
46 Views

How did you install Windows? UEFI mode or Legacy mode?

0 Kudos
Highlighted
Beginner
46 Views

UEFI, Legacy has been off since I got it

0 Kudos
Highlighted
Beginner
46 Views

I have just thought it might be and issue with the read/write speed of the hard drive and it might be faulty, going to look at it when I get home.

0 Kudos
Highlighted
Super User Retired Employee
46 Views

No, that's not it. You have a eMMC SSD built into this ICS. They're not the fastest (understatement), I agree, but not responsible for this issue (well, not unless it is defective, but defective eMMC SSDs usually just don't work at all).

0 Kudos
Highlighted
Beginner
46 Views

having the exact same issue - anyone have a fix please email me terrydonaldson@outlook.com - thanks

0 Kudos