Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MMizi
Novice
3,668 Views

Disabled Screen Scaling for Intel Computa Stick

Screen scaling In Intel HD Graphics Control Panel is not working.

It means that there is no option to scale down the desktop image in full HD rez 1080p to fit in 50+" TV.

Strangely the same desktop fits much better (whilst still not ideally) for 42" TV.

 

I'm guessing that it is not a big news for Intel engineers, but the problem should be addressed ASAP as this deficiency compromises the main selling point for the huge "Wintel mini-PC for Lounge Room " market segment

Tags (1)
18 Replies
IUman
Honored Contributor II
139 Views

Hello Mikhail_M,

Thank you for joining the Intel communities.

Our engineering department is aware of this issue and they are working in order to have the scaling option for desktop.

Hopefully a new driver version will come up soon with this option.

I apologize for any inconvenience.

Thanks!

Ronny_G_Intel
Moderator
139 Views

Hi Mikhail_M,

I work for Intel Customer Support and we are investigating on this issue.

I cant promise any quick solution (or a solution at all) but I am going to get back to this community post with an update as soon as possible.

 

Regards,

PJami
Beginner
139 Views

I took my tv out of the fix 16x9 setting in it's menu and it corrected the over scaling problem.

MMizi
Novice
139 Views

Philberg,

Adjusting 16:9 in TV setting is not a solution as, whilst fixing the TV setting for one input inadvertently affects the screen geometry for other inputs, e'g. DVD, Free-to-Air TV etc.

Screen scaling should be adjusted via application setting, in this particular case in Intel HD Graphics Control Panel. Period.

PJami
Beginner
139 Views

My lg tv has a just scan setting that adjust the tv to the components output. All the hdmi feeds to the

tv look and act normal.

Ronny_G_Intel
Moderator
139 Views

Hi Mikhail_M,

 

We tried with some different TVs (different sizes) and didn't experience the issue that you described, in both cases the TVs adjusted and image looked normal.

Do you have the option of trying it on a different TV, different brand perhaps? I am just guessing that with the amount of different TVs out on the market with different technologies and capabilities it is possible that not everything works as expected .

 

Regards,

 

 

MMizi
Novice
139 Views

I've tried 3 different TVs: older Pioneer (1368x768), more recent Hisense (1920x1080) and Samsung (1920x1080).

All of then show the same deficiency (larger desktop image).

Whilst the same TVsets being connected to a dirty-cheap Android boxes running either Jelly Bin 4.2.2 or KitKat 4.4.2 easily can be adjusted via Android's "Screen Size" applet.

Thia is why I say that such an adjustment is a software (Graphicd driver and tools) feature, which is missing (disabled) in Intel HD Graphics Control Panel for Win10..

TYan3
New Contributor I
139 Views

Well I think most TV has overscan option and probably even enable it by default (My panasonic does IIRC), it's just a matter whether they allows you to disable it.

TYan3
New Contributor I
139 Views

I actually don't understand what kind of scaling you are talking about. Do you mean the font size thing? Or your TVs weirdly doesn't take 1080p signal well?

MMizi
Novice
139 Views

Tom,

I'm talking about Windows desktop image which is some 10% larger than viewable area of TV. This results in the cropped top, bottom left and right sides, so a few things are not visible (e.g. "Start button).

The desktop area should be proportionally shrunk (it is called "scaling") to make the whole desktop area visible and accessible.

 

(
TYan3
New Contributor I
139 Views

I think you are talking about the overscan thing.

There should be a setting in your TV to disable overscan. It's mostly silly anyway.

Although drivers might have feature dealing with it (i.e. shrunk it and add black borders to the signal). I think nvidia has that but I am not sure if intel does. I don't deem it as a compulsory thing though coz a sane TV should simply have setting to disable overscan no matter if they are expected to use as PC monitors or not.

MMizi
Novice
139 Views

Exactly right Tom: both Nvidia and AMD graphics setting tools (SOFTWARE) do have such a functionality whilst Intel does not.

After all Intel Computa Stick ios a consumer (mums-n-dads) product and must have convenient and simple controlling mechanisms.

TYan3
New Contributor I
139 Views

Well at least some Intel HD Graphics (driver) does has feature to deal with overscan. For example Haswell iGPU (Customize Aspect Ratio and sliders and the right):

https://ptpb.pw/vBaK.PNG https://ptpb.pw/vBaK.PNG

Not sure if it involves hardware capabilities or Intel just don't want to give us too much feature on low end product like ICS. (Or does the ICS driver actually have that option as well?)

However, Intel does it pretty primitively anyway. Unlike nvidia, which actually resize the the desktop, it simply downscale it.

Anyway, have you checked whether your TV has an option for you to disable overscan? It's the most simple and convenient way and I doubt how often you want overscan even for video discs, not to mention that your dvd/bluray player probably has option to do overscan too and your TV might even remember overscan setting per HDMI port.

LoneWolf
Novice
139 Views

This is exactly the issue I am having with my Braswell Pentium N3700 system and Panasonic plasma 720p set. And I cannot adjust my TV, so when I had an Intel Haswell iGPU (HD 4600), I was able to size, just like Tom showed above:

This option, available with my Core i5-4590S (and prior to that, my Ivy Bridge Core i3-3225), is completely absent from the newer iGPU in my N3700. And it is essential to me. I do not understand why Intel has seen fit to remove what I consider a "cannot-do-without" feature when it was already available in previous iterations of Intel HD Graphics control panels, especially when my new GPU has been touted for its H.265 HEVC hardware decoding, something I would be likely to use on a television.

NC3
Beginner
139 Views

Mikhail, firstly I appreciate this doesn't address the point you've made concerning better software control / management options, but it fixed my ICS display issues and performance has noticeably improved. You may have found it already but for any one else who has recently purchased one of these ICS sticks with the issues Mikhail described then try this.. Solution is applicable to Samsung TVs but has been confirmed to also work on other brands. Its an old article but obviously been an issue for a while..

Link to first article http://www.storageforum.net/forum/showthread.php/8905-How-to-Disable-overscan-on-a-Samsung-quot-SMAR... here

Another more recent article http://icomputestick.com/intel-compute-stick-overscan-fix-for-samsung-tvs/ here

Essentially it's ensuring the stick is connected to a HDMI / DVI port, selecting DVI PC as the source profile, this disables overscan and the picture then fits beautifully.

idata
Community Manager
139 Views

Same issue here. Connected my STCK1A32WFC on a LG smart TV but all 4 edges of the screen are outside of view! Does anybody can help me, please?!

IUman
Honored Contributor II
139 Views

Hi all,

You will be able to get more detailed information about scaling at the following thread:

/thread/77746?start=60&tstart=0 https://communities.intel.com/thread/77746?start=60&tstart=0

Regards,

Ivan

bbob3
Beginner
139 Views

Is there any progress on enabling a scaling option for the Bay Trail compute stick, to eliminate the overscan issue? This cannot be corrected on my older (2006) Samsung plasma, and without a fix, the compute stick is pretty much useless for me. The widely circulated workarounds of naming the HDMI as PC or PC/DVI do not work on the older model Samsungs, as others are experiencing.

Reply