Community
cancel
Showing results for 
Search instead for 
Did you mean: 
UWong
Beginner
1,645 Views

How to reset the UEFI settings for compute stick (China brand Z8300)? There is no display output after I have changed some setting in some UEFI items.

I have changed some settings in some items in the UEFI of my compute stick. After a reboot, there is no display output.

I can't find anything like the "reset BIOS/UEFI jumper".

Tags (1)
0 Kudos
7 Replies
n_scott_pearson
Super User Retired Employee
87 Views

Power off ICS completely. Then, when you power it on, hold the power button in for a few seconds. You should get to the recovery menu and be able to reset the bad settings...

Hope this helps,

...S

UWong
Beginner
87 Views

Thanks for the prompt reply. However, there is still no display output by your method.

n_scott_pearson
Super User Retired Employee
87 Views

When you plug in the power brick, the ICS will attempt to start automatically. At this point, press and hold the power button down for ~4 seconds, until the blue LED turns off completely. Then, press and hold the power button down for ~3 seconds. You should see the power button menu. If you don't, unplug the power brick and start again - and repeat; it should go eventually...

If it doesn't, something may have failed in the unit. In this case - and you cannot get your place-of-purchase to replace it - contact Intel Customer Support to arrange replacement via the RMA process. Here is geography-specific contact information:

http://www.intel.com/content/www/us/en/support/contact-support.html# @11 Intel Customer Support Contact Information for US and Canada

http://www.intel.com/content/www/us/en/support/contact-support/emea-contact.html Intel Customer Support Contact Information for Europe, Middle East and Africa

http://www.intel.com/content/www/us/en/support/contact-support/apac-contact.html Intel Customer Support Contact Information for Asia-Pacific

http://www.intel.la/content/www/xl/es/support/contact-support/lar-contact.html Intel Customer Support Contact Information for Latin America

Hope this helps,

...S

idata
Community Manager
87 Views

Hello Ultraman,

 

 

When you turn on the Intel® Compute stick the LED is on? If yes, try to unplug everything and plug it back again and make sure the HDMI cable is plug correctly or try another HDMI port is it possible, and then try to do N. Scott Pearson recommendation again.

 

 

Press and hold the power button down for 3 seconds. Release it before the 4-second shutdown override.

 

 

 

Regards,

 

 

 

Ivan.

 

UWong
Beginner
87 Views

Thanks for the instructions and I have been trying...

Yes, the LED is "ON". And, mine is NOT "Intel" compute stick. Actually, it is "some China brand" Z8300 mini-pc which is almost the same configuration as Intel compute stick.

The worst thing is the seller (Taobao) disappears some time after my purchase

As a result, I don't think I could RMA it to Intel.

idata
Community Manager
87 Views

In this case if it is a Chinese component you will need to contact the seller for support and RMA.

 

 

Regards,

 

 

Ivan
UWong
Beginner
87 Views

As I mentioned before, the seller disappears!!! and I could not find any help from them.

So, here is my last hope - I am looking for, if any, special tricks / system software could help.

Thank your for the help

Reply