Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
5,523 Views

I can turn on Compute Stick without connect HDMI to screen?

Jump to solution

I need turn on Compute Stick ( with Ubuntu/Debian ), but without screen connected. This is possible?

Thanks!

Tags (1)
0 Kudos

Accepted Solutions
Highlighted
New Contributor III
725 Views

To boot Ubuntu in text mode rather than with a GUI you only need to change GRUB's configuration file. Edit the file '/etc/default/grub' and change the line that starts 'GRUB_CMDLINE_LINUX_DEFAULT=' to 'GRUB_CMDLINE_LINUX_DEFAULT="quiet text". As you will be booting effectively as a headless server then it also makes sense to change any timeouts to zero. Therefore set both 'GRUB_HIDDEN_TIMEOUT=' and 'GRUB_TIMEOUT=' to '0'. Additionally set the default boot option to match the appropriate menu option noting that zero represents the first selection. You modified file should then look similar in part to:

GRUB_DEFAULT=0

GRUB_HIDDEN_TIMEOUT=0

GRUB_TIMEOUT=0

GRUB_CMDLINE_LINUX_DEFAULT="quiet text"

Finally as root run the command 'update-grub2' to effect the changes.

And if having logged in on the console you find you want to start your default GUI, then simply run 'service lightdm start' as root.

View solution in original post

23 Replies
Highlighted
Beginner
725 Views

This should be possible. Just do not plug in the HDMI into the TV or monitor. Make sure you have a power source via USB or the Power adapter and then press the power button of the compute stick.

0 Kudos
Highlighted
Beginner
725 Views

Thank you for response, but my compute stick appears down when I try connect by ssh and don't plug HDMI.

Any idea?

My Compute Stick is STCK1A32WFC and have Debian 8 with kernel 3.19 for install the wi-fi drivers.

0 Kudos
Highlighted
Beginner
725 Views

If you don't connect the ICS to a screen with HDMI, you definitely won't be able to start it. Is very frustrating...

I tried to install Debian 8 and Ubuntu Server and I have the same situation. I updated the BIOS and nothing change.

Anybody can confirm this please?

0 Kudos
Highlighted
Beginner
725 Views

Yes i can confirm this.

If i connect my ICS with my screen after I powered it on (> 5-10 seconds), the screen stays black. My usb keyboard, usb hub, usb mouse etc. gets power but my wifi stick stays inactive. I can only press strg-alt-del for rebooting.

If i disconnect my ICS after I powered it on (30/40 seconds), it still works fine. My wifi stick works and I can use ssh etc.

The ICS must be connected with a powered screen. Just a connected hdmi cable or a hdmi<->dvi adapter does not work.

I guess i could be something with the BIOS or grub.

I found that post:

0 Kudos
Highlighted
Novice
725 Views

This doesnt seem to be an issue with the Windows 8.1 version.

Well I should state that I would still consider it an issue as it takes a very long time for the ICS to recognize the hdmi is now connected and needs the mouse needs to be *reset*.

I will have to test it again since I have changed my BIOS settings to keep power off when connected to a power source to prevent this type of issue from happening other than when I mean for it to.

0 Kudos
Highlighted
Novice
725 Views

I would like to amend my previous post, it does seem that this is not an issue on windows 8.1 ICS, i tried wtih the BIOS setting with power always on and power always off, being that I thought it made a difference when I had changed it, however, it does not make a difference and the ICS boots fine regardless and doesnt need to be plugged in to the hdmi before you turn the device on.

0 Kudos
Highlighted
Beginner
725 Views

I have news, I think that the problem is on OS side.

I tried to turn on without HDMI connected with pre-installed Windows and all works fine. The same test with Debian 8 without X ( desktop environment ) and not starts.

Now I'm trying to compile the last Linux kernel ( 4.12 ) with new graphic drivers. If this not change anything the next step is try to install Debian 8 with X, and if fails also the last test is install Ubuntu 14.04 without X and with X.

I reply this post with the next bad or good news...

0 Kudos
Highlighted
Beginner
725 Views

- Debian 8.1 WITHOUT desktop environment with kernel 4.12 not start ICS.

- Debian 8.1 WITH desktop environment with kernet 3.16 not start ICS.

...

0 Kudos
Highlighted
Beginner
725 Views

I have bad news... ubuntu fails with all kernels and versions..

I'm trying to install Ubuntu 32bits in to windows boot.

0 Kudos
Highlighted
Beginner
725 Views

Hi, ICS can boot Ubuntu 14.04LTS without HDMI connection.

I think this problem would occured by grub.

Please make edit /etc/default/grub and update-grub2 as follows.

http://www.geocities.jp/cowfish_lactoria/intel0.6-euc.html Intel Compute Stick part 0.6 - Headless with Ubuntu Studio 14.04LTS

But, at a later date, if you change kernel image, (only a)next boot may fails without HDMI connection.

0 Kudos
Highlighted
Beginner
725 Views

Hi lactoria,

You can explain me the installation process or is a normal installation ?

1. Select ubuntu in BIOS

2. Insert USB or MicroSD bootable.

3. Install.

4. Edit the grub.

5. Enjoy?

Thanks a lot!

UPDATE 1: I tried your solution and not start ICS, please tell me your installation process

0 Kudos
Highlighted
Beginner
725 Views

Hi rafaaguilar,

If you set "Ubuntu 64bit" in BIOS, installation process is a "very normal" Ubuntu installation just like a PC.

Of course, You need monitor screen at first install of Ubuntu...

I find you in other thread, You installed Linuxium's special iso image.

The difference is..

I used "Normal" Ubuntu Studio 14.04LTS iso image from Official Ubuntu site, and change kernel to realtime kernel 3.18.xx.

But.. I think "realtime kernel" is not a cause of fail to boot headless...

Oh, I forgot! I was installing latest "grub" from github! This should be a BIG difference point..may be..

If possible, try to install latest grub from git!!

0 Kudos
Highlighted
Beginner
725 Views

I can confirm the Windows ICS with Ubuntu 14.04 won't boot unless connected to a HDMI screen. I have tried the grub modifications linked above with no luck.

0 Kudos
Highlighted
Beginner
725 Views

Hi ScubaShan,

Just now, My ICS (Windows ICS) with Ubuntu 14.04 Studio(and some modification..) boot without HDMI.

May be something lack...

Please try latest "grub" from git and install in the following way.

# apt-get install git bison libopts25 libselinux1-dev autogen m4 autoconf help2man libopts25-dev flex libfont-freetype-perl automake autotools-dev libfreetype6

-dev texinfo

# git clone git://git.savannah.gnu.org/grub.git

# cd grub

# ./autogen.sh

# ./configure --with-platform=efi --target=x86_64 --program-prefix=""

# make

# cd grub-core/

# ../grub-install -d . --efi-directory /boot/efi/ --target=x86_64

# cd /boot/efi/EFI/ubuntu/

# mv grubx64.efi grubx64.efi.org

# cp ../grub/grubx64.efi .

 

And my current /etc/default/grub is(except ^# )

 

 

GRUB_DEFAULT=0

GRUB_RECORDFAIL_TIMEOUT=2

GRUB_HIDDEN_TIMEOUT=0

GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`

GRUB_CMDLINE_LINUX_DEFAULT="quiet text clocksource=hpet intel_pstate=disable reboot=pci"

GRUB_DISABLE_OS_PROBER=true

 

 

 

Furthermore, You need following setting for uninterrupted fsck checking

in /etc/default/rcS, FSCKFIX=no changes to FSCKFIX=yes

 

 

And, execute update-grub2, You should better boot with HDMI monitor and reboot.

Everything OK, unplugged HDMI cable and try to boot!

 

--------------------

 

 

Additional comment in 27 Jul.

GRUB_CMDLINE_LINUX_DEFAULT="quiet text clocksource=hpet intel_pstate=disable reboot=pci"

may need some modification. this is effect only my special kernel(Use hpet and never use intel_pstate).

 

try this!

 

GRUB_CMDLINE_LINUX_DEFAULT="quiet text reboot=pci"

 

0 Kudos
Highlighted
Beginner
725 Views

Thanks Lactoria, but for the moment I can't start without HDMI following your steps.

How install Ubuntu? Deleting Windows and using all disk for Ubuntu or resizing the Windows partition?

0 Kudos
Highlighted
New Contributor III
726 Views

To boot Ubuntu in text mode rather than with a GUI you only need to change GRUB's configuration file. Edit the file '/etc/default/grub' and change the line that starts 'GRUB_CMDLINE_LINUX_DEFAULT=' to 'GRUB_CMDLINE_LINUX_DEFAULT="quiet text". As you will be booting effectively as a headless server then it also makes sense to change any timeouts to zero. Therefore set both 'GRUB_HIDDEN_TIMEOUT=' and 'GRUB_TIMEOUT=' to '0'. Additionally set the default boot option to match the appropriate menu option noting that zero represents the first selection. You modified file should then look similar in part to:

GRUB_DEFAULT=0

GRUB_HIDDEN_TIMEOUT=0

GRUB_TIMEOUT=0

GRUB_CMDLINE_LINUX_DEFAULT="quiet text"

Finally as root run the command 'update-grub2' to effect the changes.

And if having logged in on the console you find you want to start your default GUI, then simply run 'service lightdm start' as root.

View solution in original post

Highlighted
Beginner
725 Views

Hi rafaaguilar,

I install Ubuntu as followings.

1. resize Windows partition from Windows disk manager

2. Select ubuntu in BIOS

3. Insert Ubuntu bootable USB media.

4. Boot 'Try ubuntu' and Install ubuntu.

You need USB Wifi dongle (or LAN adaptor) supported in Ubuntu.

because, ICS's Internal Wifi module need some configuration steps for use. (may hard to work because there is no Internet connections now!)

After connect internet, Select 'Install ubuntu' icon and start install Ubuntu.

But, in this step, ubuntu cannot find any Windows system because of 64bit UEFI setting in BIOS.

I don't care Windows but I will leave the time being... Windows may be unbootable now.

Install Ubuntu in /dev/mmcblk0p5 and install EFI in /dev/mmcblk0p1

 

5. Install latest grub from git and edit /etc/default/grub... see my previous post.

6. Enjoy!

I used official Ubuntu 14.04 Studio ISO, but linuxium's special ISO may be more useful for ICS.(but I don't try yet. sorry.)

0 Kudos
Highlighted
Beginner
725 Views

YESSS!

This is the solution, works fine with Ubuntu and Debian!!! It's fantastic!!!

Only modify these lines in grub configuration, reboot and 'voilà'..

Thank you so much linuxium and lactoria for your time and patience!!!

0 Kudos
Highlighted
Beginner
725 Views

Hi

I have been testing your guide, without success

stick to the cp ../grub/grubx64.efi can not find this file, which I will place under the /boot/efi/EFI/ubuntu

Is the filen in Git packages?

0 Kudos