Intel® Compute Stick
Support for Intel® Compute Sticks and Cards
Announcements
Do you have improvements you would like us to make on this community site? If so, we would love to hear your feedback! Click here for an 8 question survey. Thanks!

523 Discussions

with using compute stick wireless wi-fi, the wi-fi signal is cut off...

nkim8
Beginner
1,091 Views

With using compute stick wireless wi-fi, the wi-fi signal is cut off- phenomenon occurs whenever I was downloading a large data like as torrent...this make me crazy!

But, at the same time, my cellular was working good downloading with same wi-fi from same router!

what's going on my stick?

0 Kudos
1 Solution
IUman
Honored Contributor II
195 Views

The onboard Realtek RTL8723BS wireless adapter is an SDIO adapter; SDIO is slower than PCIe-based wireless adapters. Wi-Fi speeds can be very slow, depending on many factors:

If there are other Wi-Fi routers nearby. Router channel is set to Auto (and so is everyone else's).

How close the unit is to the router (router is in another room; signal passes through walls/floors).

Interference from other devices (mobile phones, cordless phones, microwaves, Bluetooth devices, or baby monitors.

You can try the following:

Eliminate interference with nearby wireless devices (like microwave, cordless phones).

Experiment with setting the router channel to a specific one, not Auto. Note: 2.4GHz can use channels 1, 6, and 11.

Try hooking a second router or a router extender to your main router to spread the signal throughout the house.

Disable the onboard wireless in BIOS and use a USB-based Ethernet adapter. Wired Ethernet is always going to be faster than Wi-Fi.

View solution in original post

1 Reply
IUman
Honored Contributor II
196 Views

The onboard Realtek RTL8723BS wireless adapter is an SDIO adapter; SDIO is slower than PCIe-based wireless adapters. Wi-Fi speeds can be very slow, depending on many factors:

If there are other Wi-Fi routers nearby. Router channel is set to Auto (and so is everyone else's).

How close the unit is to the router (router is in another room; signal passes through walls/floors).

Interference from other devices (mobile phones, cordless phones, microwaves, Bluetooth devices, or baby monitors.

You can try the following:

Eliminate interference with nearby wireless devices (like microwave, cordless phones).

Experiment with setting the router channel to a specific one, not Auto. Note: 2.4GHz can use channels 1, 6, and 11.

Try hooking a second router or a router extender to your main router to spread the signal throughout the house.

Disable the onboard wireless in BIOS and use a USB-based Ethernet adapter. Wired Ethernet is always going to be faster than Wi-Fi.

View solution in original post

Reply