Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Community Manager
858 Views

2600K & DP67BG Turbo Boost "Throttling"

I wasn't sure if I should post this in the processors forum, or here. But I believe it to be a problem with my board, so this forum is where I will post my problem.

My Turbo Boost is being throttled. I have my CPU set to boost to 4.5GHz in the BIOS (45 Multiplier - Base Clock remains at the stock 100). Thing is, when I tax the processor to 100%, my clock only reaches 3.4 - 3.6 GHZ, never more. The BIOS reports it to be 4.5GHz, like it should be. But when in Windows, it never reaches that speed.

I am running the latest BIOS version: BGP6710J.86A.2111.2011.1120.2157 (2111). Unfortunately, I can't remember if this problem started when I updated to the latest BIOS, or before. I didn't notice it until last night. This problem hasn't always been. I used to be able to reach 4.6GHz @ 1.25V (I'm one of the lucky ones when it comes to processor's).

I've tried resetting all performance related settings to default values; using the (*cheat*) Automatic O/C settings in the BIOS, and so far have not been able to pinpoint what is causing this. Any help would be appreciated. Even guessing troubleshooting that I haven't though of would be appreciated.

Specs:

- i7 2600K

- Extreme Series DP67BG

- 8GB Crucial Vengeance DDR3 1600

- 2x GTX 580 SLI

- Sound Blaster X-Fi Titanium HD

- PC Power and Cooling 1200W PSU

- W7 x64 Pro

EDIT:

Immediately after posting this, I read the related posts, and it appears to be a problem with Intel's latest BIOS revision. Intel fooked it. So, I am going to roll back and see if it corrects the problem. Other people have had success rolling back.

0 Kudos