Intel® Desktop Boards
Peer-to-peer support only
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11460 Discussions

After updating DZ77RE-75K to 11/15/12 BIOS no HD and no external video


Just updated my DZ77RE-75K to the latest 11/15/12 BIOS and rebooted to get two beeps for no video. Removed video card and attached monitor to MB HDMI port and did get video however BIOS shows no hard drives. System has two SSD and four 1TB hard drives in two RAID arrays. Nothing showing now.

Further troubleshooting finds the RAID controller appears to be bad. In AHCI mode BIOS shows all six drives but in RAID mode they are gone. Tried last four BIOS and same problem. Tried removing CMOS battery for an hour and makes not difference. Can see drives in AHCI but not RAID mode. Getting replacement from Amazon tomorrow. Amazon is wonderful about exchanges. Shipping overnight.

Message was edited by: Scott Horne

0 Kudos
0 Replies