Intel® Desktop Boards
Peer-to-peer support only
11432 Discussions

BIOS upgrade problem on DZ77GA-70K desktop board


I tried to upgrade my BIOS (0021) to actual version (0066). I was successfully download the express BIOS update tool, I started on Windows 7. After the reboot the computer switched on for about 10 sec after switch off and switched on for 10 sec ... About 5 min I switched off the computer. I wait a 2-3 min after switch back. In this step does not effect for a 10 mins. After this step I tried the BIOS recovery procedure (download the GA0066.BIO file, write to an empty CD, put to the CDROM, switch off the computer, unplug from line, remove the BIOS recovery jumper, plug to the line, switch on... I see the power led flashing and CD is work (LED on CD flashing), after a few mins the power LED still continous light and CD is stoped, and computer is restarted and the monitor I see the "intel icon" on the left upper corner, after my monitor go black. I wait a few mins, and switch off (unplug from line etc.) my computer plug the jumper to "normal" position and switch on. The monitor is black, and board beep 3 times (beep-silence-beep-silence-beep long silence and beep-silence-beep-silence-beep long silence ...). When I switch on the computer a very short time I see "14" after continous "15" code on the 7 segment display on board.

What Can I do in this situation for working computer?

0 Kudos
1 Reply

Hello Gaborvidg,

The problem could be that you are updating the BIOS from a very old version (0021) to latest version 0066.

This specific model has 15 different BIOS versions, which means there are many fixes between one and another.

What we recommend customers to do is to check how many versions are between the current BIOS and the latest one. Then, depending on that, install or flash 1 or 2 versions before getting to the latest one.

The following link has the release notes for all BIOS versions available for your motherboard

At this moment you can try to install BIOS version 0021 again using the BIOS recovery method.

Once you are able to access the BIOS, you can try to install BIOS v0035 and so on.