Intel® Desktop Boards
Peer-to-peer support only
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11463 Discussions

Black screen with DZ77GAL-70K motherboard

Community Manager

Hi members of the Intel community!


Today I put together a new build and I am running into some problems. First of all, I was having some problems with the RAM. I tried different XMP profiles, timings, etc... and to no avail. I did update to the latest BIOS for my motherboard.The last thing that I tried (which created a new problem) was enabled UEFI boot and disabled legacy boot. I figured I would give UEFI a try. Upon restart, nothing would be displayed on any of my monitors. There isn't even a black screen to indicate that some sort of signal is getting through. Below is my current build.



Motherboard: DZ77GAL-70k (flashed to the newest BIOS version)

CPU: Intel Core I7-3770k

RAM: GSkill Trident 2x8GB 2400mhz (F3-2400C10D-16GTX)

HDD 1: Intel Solid State Harddrive 520 series

HDD 2: Western Digital Caviar Black 640gb HDD

GPU: Nvidia Geforce 670 GTX FTW

Power Supply: Corsair 850w power supply


Things I have tried.


  • Removing all PCI cards and hooking into the onboard HDMI port.
  • Removing all HDD's
  • Switched out RAM with Corsair Dominator 1600 2x2gb.
  • Resetting BIOS through the use of the jumper.


Nothing so far has worked. I have not been able to display a picture on the screen. I will try removing the CMOS battery for at least 5 minutes and see if that works. If that does however not work, then are there any suggestions out there as to what I can do to get a picture displayed?


Thanks for your time!


0 Kudos
6 Replies
Community Manager

Don't disable Legacy Boot if you don't have a Nvidia 600 series card with UEFI firmware on it.

Hold down power button for 3-4 seconds and release to get back into firmware settings.

Community Manager

Hold the power button down 3-4 seconds at any old time? Should I have my GPU still plugged in and monitors hooked to that? Or should I hook the HDMI up to the onboard?

Community Manager

Hmm.. wtf i just noticed that my reply appeared several times in row. Deleted the duplicated now.

If you have your PCI-E GPU plugged in then press power button, hold it for 3-4 seconds and release and it will take you into firmware settings or you can use IGP instead and then you don't need to hold power button because the IGP works with Legacy Boot disabled. IGP has UEFI firmware. Note that IGP must be enabled in the firmware settings before you can use it, if it is set to disabled then you must hold power button & release.

Community Manager

When I hold the power button while booting the motherboard beeps with error code "10" being displayed on the motherboard. If I hold it while shutting down, the PC will shut off and then restart but still with nothing being displayed. I tried the integrated and I tried the GPU as well.

Community Manager

I found the following link on recovering the BIOS Desktop Boards — Instructions for Recovery BIOS update

I followed the directions on there to recover the BIOS with a USB drive. It worked on my 2nd attempt.

Thanks for the replies!


I had a very similar problem.

You cannot disable Legacy if you did not install Windows 8 as UEFI and went through a procedure. You can check to see what your windows install is by doing a Windows key + R and typing: msinfo32

Under BIOS Mode, check to see if its UEFI or Legacy.

If its Legacy and you want UEFI, you need to re-install using a UEFI Boot disk or an original windows 8 DVD that has UEFI on it.

If your BIOS Mode is Legacy and you try to disable Legacy, your computer wont even post. Happened to me. I needed to press the square button that lights up red on the back of the MB to be able to boot back into BIOS and enable Legacy.

Also make sure your video card is UPDATED with the latest BIOS so it can boot into UEFI. I had a nightmare last night trying to install Windows 8 UEFI with an outdated BIOS on my GTX660 TI. I had enabled my IGP to always be on in the BIOS. But when I booted up, I only got video on my monitor through the HDMI cable connected from my MB to monitor. And then once I logged in, i would get video from my GTX660 TI GPU. So it was weird, if i had my monitor set to the DVI input from my Video Card, when I started my computer, the screen would look black for a few seconds while computer booted up in the background and then suddenly just turn on at login screen. It was because it was displaying all the post info through the HDMI (IGP) and then kicking into the GPU. So make sure you have an updated BIOS on Video Card and that it supports UEFI.

Hope this helps. Now to go make another post about trying to go make Secure Boot work