Intel® Desktop Boards
Peer-to-peer support only
11478 Discussions

Boot Manager almost empty


Dear community,

I have a problem with my DH87RL (Rev 401) with the latest Bios-Version RL0326.

After installing Win 8.1 64bit on the SSD (8 months ago) everything was fine. I have 2 optical drives, a SSD (EVO 840) and a Seagate HD (also with bootable Win 8.1). All these drives were shown in BIOS and in the boot-manager (UEFI mode and legacy mode). When I pluged in a USB stick (e.g. Ubunto or Win PE) I could also see it in the BIOS and the boot manager and I was able to boot from the stick.

Now I have the following problem: I couldn't boot from a USB-boot-stick that was displayed in the boot manager. Therefore I disabled the legacy mode and once I had booted again I switched it back on.

Now when I choose the boot-manager using F10, only my SSD and the UEFI : LAN connection are displayed. The Seagate-HD and every USB-boot-stick are missing. In BIOS, under UEFI boot page, all drives (except the optical drives) are available and I can boot from the HD with a double click. Under the legacy boot settings everything (optical drives) is missing

I already tried the default values without success.

I assume that I should erase the NVRAM or are there other solutions for this problem?

If I must erase the NVRAM, how best to do it (remove the BIOS battery)?

Thanks Mike

0 Kudos
5 Replies

Hello PC-Wizard,

In fact I would recommend you starting clearing the CMOS.

The easiest way to clear the CMOS is to restore the factory defaults from within the BIOS.

  1. Access the BIOS on Intel(R) Desktop Boards by pressing the "F2" key when booting up.
  2. Press "F9" to be prompted to "Reset BIOS Settings".

Clear the CMOS using the motherboard jumper:

This option involves opening the system and moving a jumper on the motherboard.

  1. Power off the system.
  2. Open the system up so you can see the motherboard.
  3. Locate the yellow or orange jumper usually located near the BIOS chip or near the CMOS batter. (Refer to the Technical Product Specification for the board to details.)
  4. The jumper should be set on jumpers 1-2. Move the jumper to the 2-3 position.
  5. Power on the system and enter the BIOS to reset to the factory defaults, following the steps above.
  6. After resetting the defaults, power off the system and return the jumper to the 1-2 position.

Clear the CMOS by reseating the CMOS Battery:

This option involves opening the system and accessing the CMOS battery on the motherboard.

  1. Power off your system and unplug the power source from the power outlet.
  2. Open the system up so you can see the motherboard.
  3. Locate the CMOS battery. (Refer to the Technical Product Specification for the board to details.)
  4. Remove the CMOS battery carefully and leave it out for 15-20 minutes.
  5. Reseat the CMOS battery and power on the system.

I would also like to know the size of the USB stick and the HDD you are trying to boot from.

Kevin M


Dear Community,

sorry for the late response. My problem is now becoming worse and more difficult. I have tried the above procedures and I am now able to find the SSD, HD and the optical drives in the boot- manager.

But during the whole procedure and many booting-actions I suddenly heard a beep during booting and the BIOS Setting "Keyboard ready beeps" was suddenly activated. Everytime I uncheck this and save this setting, in the next boot action it was activated again and I heard the same annoying beep. Although in the BIOS-menue: "Boot Display Config" the setting: "Display F2 to Enter Setup" was checked, it will not be displayed during the boot process (F10 was). When I deactivate and activate it, it is randomly displayed. This also happens with the setting: "Post code routing": LPC Debug Header or PCI.

The most curious thing is that even when I unplug the keyboard, the beep still comes.

Any other changes in BIOS are stored as given. Only the settings in "Boot Display Config" are affected!

I have tried the following actions to fix the problem, without success:

Load defaults (F9)

Clear the CMOS battery

Put the jumper on the motherboard in the 2-3 position and back to 1-2

Changing the setting in "post code routing" in LPC Debug Header (this setting disappeared randomly at the next boot)

Any suggestions?

Thanks Mike


I understand and I am sorry you are having this issue.

You can try a BIOS Recovery process to reestablish all configurations. Here are the steps:

IF issue persists, after doing all the steps mentioned before I recommend you contacting your local support for them to check the unit or a possible replacement if necessary.

Here is our contact information:

Kevin M


Hi Kevin,

thank you for your reply.

Is there a difference between a regular and recovery BIOS update?

I have tried a regular BIOS update without success.



The BIOS Recovery process will get all components from the BIOS and fix errors if there are. BIOS update normal process will just add some more features.

Kevin M