Intel® Desktop Boards
Peer-to-peer support only
11436 Discussions

Boot problem with mSATA disk (BIOS bug?)


Hello everyone,

my new PC doesn't boot from the built in mSATA disk on power up.

If I enter the Visual BIOS and double-click the mSATA disk the system boots. Or if I press F10 after power up and get the boot menu the mSATA disk is the second entry and I can boot from it. But if I just turn on the PC and wait I end up with a black screen and a blinking cursor in the upper left corner. Of course the mSATA disk is on top of the boot order.


Intel Desktop Board DH77DF

BIOS Version: KCH7710H.86A.0110.2013.0513.1018

Intel Core i7-3770T CPU @ 2.50GHz

Memory 2 x 8GB @ 1333MHz


mSATA disk - "SATA : PORT 4 : Kingston SMS200S3120G : PART 0 : Boot Drive"

hard disk - "SATA : PORT 6G 0 : HGST HTS541010A9E680 : PART 0 : Boot Drive"

I already tried a lot of things (all with no positive effect):

- I experimented with many BIOS options, disabled almost any speed-up options

- I contacted my PC manufactorer and got a new mSATA disk

- BIOS update

- I took out the hard disk (so there was only the mSATA disk as boot device) and got an error "A bootable device has not been detected ..."

Since the BIOS shows the mSATA disk correctly and I already testet 2 mSATA disks, for me it looks more like a BIOS bug than a hardware problem. Has anyone here made similar experiences?


0 Kudos
2 Replies

Hi Fred34,

Make sure you do not have any other device connected to the motherboard such as USB devices. I also recommend you accessing the bios and setting it back to default settings by pressing the F9 key.

If issue persists, please post here your dxdiag report.


Hi Kevin,

thanks for your reply - it works now. I was a little bit hesistant with loading default BIOS settings because I didn't know whether the PC manufactorer made some special settings or not. But I tested it and since it worked with default settings, I wanted to know witch option made the difference. And so I found the "UEFI Boot" option to be the reason (must be checked).

But the point is that I run a debian (jessie) with grub as bootloader (standard version, non-EFI) and both disks are smaller than 2 TB (SSD: 120 GB, HD: 1 TB). Because of this it never came in my mind to activate "UEFI Boot". It still works without the "UEFI Boot" option using the F10-boot-menu or by clicking the disk in Visual BIOS. Even more direct booting works without this option if grub is in the MBR of my hard disk. So it still seems to me, that the BIOS treats the mSATA-SSD and the hard disk not in the same way.

However, since I got my solution I'll mark the question as answered and thank you for your help.