Intel® Desktop Boards
Peer-to-peer support only
11480 Discussions

Can't boot after bios update (Board DH61CR)



I had a really old version of bios on said board (v20) and decided to upgrade it.

The update 48 went all well. Then I did as said in the tutorial and installed version 99, After that the computer couldnt boot into windows, so I went into the bios settings and accidently changed something i believed to be the boot order.

After that, I couldnt even boot into bios anymore.

So I went on and tried to use the recovery cd - the versions >99 (i tried 109 and 120) seemed to work, but after a reboot, the system still says it has version 99. The version 99 recovery didn't work at all.

If I put the jumper back on the normal position, the computer starts running and restarts after a few seconds - without showing any output and not making any signal noises (I did check if it is supported by removing the ram and it gave me a missing ram sound).

Resetting the CMOS also did nothing in regards of improving my situation (I waited way over an hour just to make sure).

I hope someone else has an idea on how to fix my problem.

(ps. The only solution i found online is to buy a new bios chip - if it is indeed my only option, what chip do I have to buy and what bios version should it have? )

0 Kudos
1 Reply

Thanks for joining the community.

I am sorry to hear the motherboard does not boot after BIOS update.

This issue does sound like bios chipset corruption. If you already tried BIOS recovery and still cannot get the system to boot up, this means the next step is replacing the board.

I regret to inform you that Intel does not provide BIOS chipset recommendations for this failure type. Intel replaces the board is you are still under 3 years of warranty.

Please contact support at: and check if the motherboard is still under warranty.