Intel® Desktop Boards
Peer-to-peer support only
11476 Discussions

Compatibility issues with DH61AG and SanDisk 64GB SSD


Hi all,

Wonder if anyone can shed any light on a situation I am having.

I have just purchased parts to build a new system for my girlfriend.



Mainboard: Intel DH61AG mini-ITX

CPU: Intel Core i3 3220 3.30GHz Ivy Bridge

Memory: 4GB Corsair 1333MHz

SSD: SanDisk 64GB SDSSDP-064G-G25 SATA3


The build went well until trying to install Windows.

When selecting the drive to install windows to it comes up with the following:


Name Total Space Free Space

Disk 0 Unallocated Space 0.0MB 0.0MB

Below is a warning link that says "Windows cannot be installed to this disk" which reads "The selected partition requires at least 5884MB free space" when you click on it. I've tried running diskpart to clean the drive which displayed:

"DiskPart has encountered an error: The request could not be performed because of an I/O error. See the System Event Log for more information."

I look into the SEL and there is no mention of this occurrance. I tried to create partition primary which resulted in:

"Virtual Disk Service error: There is not enough usable space for this operation"

I looked in the SATA devices in the BIOS and this was displayed:

SATA Port 0 Sandisk Milpit(0.0GB-3.0Gb/s)


I thought I may have a factory fault in the SSD until I installed the SSD into my own system and to my frustration, it worked.

I unplugged all other drives and successfully partitioned and formatted the SSD before installing Windows 7 Home Premium 32-bit

I then plugged it back into the other system...same errors being displayed.

The only thing I can think of is that the SATA drivers are not compatible with these SSDs?

I had the BIOS updated before being shipped to me as I am running a 3rd generation i3 processor and by factory this board would not have been able to support a 3rd gen CPU (BIOS needs to be 0036 or higher) so the supplier flashed the BIOS to the most recent release (0105).

I have since re-flashed the BIOS back to 0104 and the same errors occur. The BIOS won't flash back any further (tried 0099 to no avail).

I have also updated the firmware that controls the AHCI controllers and this has had no effect either.


I have done pretty much all I can do and all I can assume is that the controllers onboard the DH61AG are not compatible with this model of SSD?

Any thoughts?

Thanks in advance



0 Kudos
3 Replies

Hello Andy,

Here are our recommendations for this issue:

  • Try another installation disk, just in case this one is corrupt.
  • If you are using an image saved on a USB flash drive, try to create a new image.
  • There are some drivers (F6 Drivers) you can load when the Windows installation page appears. You will find the drivers you need to install on the following link. You may want to read the Read Me file first. These drivers are needed when customers want to install Windows XP, but you may want to try since they worked before when installing Windows 7 or 8.


If you are installing Windows on RAID Mode please use this link:

If you are installing Windows on AHCI Mode please use this link:

Here are the steps to follow:

  1. Unzip the file you download from the previous link on a USB flash drive.
  2. Start the Windows installation as normal and when you get to the page where you need to choose the hard drive, please click "load driver" button.

3. Click on Browse and look for the USB. Then choose the "Intel(R) Desktop/Workstation/Server Express Chipset SATA RAID Controller driver" and click next.


Once it is install you should be able to see the hard drive and continue with the installation of the OS.


Please let me know!




Sylvia L




the recommendations you have listed in your reply are not helpful in the slightest, in fact I find your reply quite patronising and insulting. If you had read my post fully and took the time to understand the problem, you would have seen that I have tried numerous different things to solve this problem, most of which render the "possible solutions" you suggested completely useless. I am quite well aware how to troubleshoot problems and I would not be posting on this site if I thought I would be treated like an idiot by the people who are supposed to be helpful.

Reasons why your suggestions are pig swill:

  • "try another installation disk" - in my post I mentioned that I installed the drive into my own PC and managed to install Windows 7 without a problem.
  • "if using a USB drive, create a new image file" - see above
  • "there are some drivers" - again, as I said in my post I have updated all of the drivers, including the ones you linked me to and even more infuriatingly, I went through the same process you took the time to lay out to me. Basically, you are trying to teach me how to suck eggs.

I would like to counter your suggestions with a couple of my own:

  • Read people's posts fully and take time to understand people's problems before you reply
  • Suggest things that are actually useful and not designed to try and make people look/feel stupid
  • Lastly - don't waste your time and mine by not doing the above

I am an advocate of Intel and have used the products produced by the company for nearly 2 decades. This is the first time I have come across a problem I have not been able to solve using my own expertise and/or using other forums on the web. I have not found any solutions to this problem on any other forums, hence I am posting on the official Intel site, and still I get treated like an idiot and like I don't know how to use the products.



Please apologized if you felt that way!

We are here to help you out, we are trying to find a solution for your problem.

I am going to do some research on this issue, since it looks like the problem is with this specific SSD and it could be related to compatibility, how you stated it on the original posted.

In the mean time, please let me know if you have tried to install Windows on IDE mode, just for testing?

I'll keep you posted.