Intel® Desktop Boards
Peer-to-peer support only
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
11358 Discussions

D5400XS - No Video

idata
Community Manager
883 Views

I bought a D5400XS from newegg when it first was released. This board had a problem where some of the PCI-e slots didn't work. I one day decided to try to test out the other pci-e slots again to buy another GPU for SLI. as a result of this, the board stopped working all together. after some back and forth warranty games intel finally agreed to sell me a replacement board.

I got the replacement board, and I should note that this was not the same board as the first one I had bought. The new board came with an updated bios, had a battery for the CMOS, and there was a sticker that wasn't on the previous version. when I first set this replacement board up, every time I wake up in the morning to turn it on, I had to press the reset button 6 times before anything on the video would show. in a bid to fix it, i flashed the bios to the latest version, and I went through all these settings in the BIOS. I decided to try to enable EFI mode because of the prospect that it would be an improvement over the BIOS, but from this point on, no matter how many times I reboot, nothing shows up on the monitor. I tried three monitors, I tried to put the GPU into all pci-e slots, with no luck. the problem now is that nothing shows up on the monitor, but I still hear windows start up. I also attempted to flash the BIOS to make sure that EFI was no longer the problem. not even the 6 reboot voodoo ritual no longer works.

FYI: I tried two pci-express GPUs and neither of them are working.

I tried to get intel to see what the problem was, so I paid to have the board shipped to them, but they sent it back because there was a minor scratch, and I don't think they really tried to do any diagnostics on it.

has anyone else had similar problem? and what can I do to fix this problem?

0 Kudos
1 Reply
idata
Community Manager
80 Views

Did you ever find a solution to your problem? Having same issue here but only 2 of the pcie.16 slots aren't working, i can put my video card into the 3rd slot and it comes up fine.

Reply