Intel® Desktop Boards
Peer-to-peer support only
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
For the latest information on Intel’s response to the Log4j/Log4Shell vulnerability, please see Intel-SA-00646
11381 Discussions

DG43RK BIOS update weirdness

Community Manager

I can't seem to get the firmware updated.

Update 0068>0070 worked fine.

Update 0070>0085 worked fine

After updating to Firmware 0086 the system locks up at the splash screen.

After updating to Firmware 0088 the system locks up at the splash screen.

So far, whether I've used a bootable USB and forced the system to update to 0086 or 0088, used the F7 option from version 0085 to update, or used the Windows update option to go from 0085>0086/88 the system locks up at the splash screen.

Any idea why I can't seem to update the BIOS? The system tells me the update was successful but obviously not.

Using on-board video, keyboard, and mouse.

0 Kudos
1 Reply
Community Manager

The on board video was causing the problem. Switched to a dedicated video card and all is good now.