Intel® Desktop Boards
Peer-to-peer support only
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11462 Discussions

DG45ID - Windows8 x64 UEFI install

idata
Community Manager
2,621 Views

I have a dg45id board and I try to install windows8 x64 with UEFI mode with Intel's last official BIOS.

In the BIOS, I turn on the UEFI boot and

I try to perfect CD from a ISO file that is match form MSDN's announced hash value to install.

Install situation is just okay.

But after the 1st install that copy form a cd to a volume, and I booted It, that crashed like below.

Middle of the korean means

" There is no kernel or some error in the kernel, I cannot load the OS."

"

Windows 7 x64 with UEFI & GTP disk just perfect on my DG45ID.

Windows 8 x64 with BIOS & MBT disk just perfect on my DG45ID.

Is DG45ID those not support windows 8's UEFI?

Or my DG45ID is just broken?

Maybe

DG45ID's UEFI version = 1.1

windows 7's UEFI support = 1.1

windows 8's UEFI support = 2.1

?

Sorry my broken English and Thank you for your attention.

0 Kudos
15 Replies
idata
Community Manager
571 Views

Just want to know if you are referring to the Release Preview of Win 8. Thanks.

idata
Community Manager
571 Views

I didn't try to. If I do it, I will report here.

Thanks.

idata
Community Manager
571 Views

Looking at the picture in your first thread it seems that you choose "Repair" when installing Windows 8. If you agree to reinstall again try not to choose "Repair" but choose "Install" instead. Of course, I assume that you have a backup of all your data before doing this.

idata
Community Manager
571 Views

I didn't choose "Repair" when installing it.

I choose "Install" and in that times it's okay.

But its first boot after make partition and volume, copy some files from CD to disk,

windows boot manager on GTP disk that is installed by Windows 8 is good. I think.

Maybe windows boot loader has some problem.

I checked it with BCDEDIT and BCDBOOT, but I can't find any error.

Anyway as I said, I did install just right way and very normally.

I make clean GTP disk and booted in UEFI but it appeared.

Of course, I checked my CD and image of Windows 8's hash value.

It's matched with MS announced.

Install with MBR disk and BIOS is just fine.

Same Windows 8 CD, same physical hard disk, same RAM, same DG45ID with that install way

except GPT and UEFI.

Install Windows 7 with GTP disk and UEFI is also fine.

Install Windows 7 with MBR disk and BIOS is also fine.

idata
Community Manager
571 Views

You may be right. It could be a defective boot loader. And this could be due to the installation process. During installation, did you delete the existing partition (if there are any) and let the program create the gpt partition as part of the installation process? Or you created the gpt partition manually first before running the Win 8 setup?

In my case I deleted the existing partition in my hdd and just let the Win 8 setup create the gpt partition as part of the installation process.

Other than this, it could also be a defective copy of Win 8. Although it has the same hash number but still we cannot be sure until we run it.

I also assumed that you have the Sata mode setting in bios set to AHCI mode.

idata
Community Manager
571 Views

I did both way but same result.

Also I've got AHCI mode.

Did you try with DG45ID?

Nobody has like my problem?

Only it's my problem?

idata
Community Manager
571 Views

First of all I did not try it on the DG45ID. I have a different mb. But I believe this has nothing to do with the mb based on what I have learned from other forum threads. In these threads the installation of Win 8 goes back to older machine and it is a success.

It could be a defective copy I suspect. I downloaded my copy from Microsoft's website not from MSDN. I tested the installation both using mbr and gpt partition starting with the CP edition up to the RP edition. And the procedure that I follow is as given in my previous thread.

Let's just wait for a while and see if others can help you out.

idata
Community Manager
571 Views

My DG45ID motherboard have the same problem. But disable AHCI can enter the system.

BVarg2
Beginner
571 Views

Ok, so it's almost 2016 and the problem is STILL UNSOLVED! 

Not e !ven if I want to install Windows 10...

I've been facing with this problem for about a week without any success.

intel_adminitpnadminintel_adminCommunityAdminintel_adminPLEASE HELP US!

AP16
Valued Contributor III
571 Views

Run the https://technet.microsoft.com/en-us/sysinternals/cc835722 Coreinfo tool in Command Prompt (Admin) and check the CMPXCHG16b line status in output.

BVarg2
Beginner
571 Views

It shows:

 

CX16 * Supports CMPXCHG16B instruction
Allan_J_Intel1
Employee
571 Views

According to the list of supported operating system. Windows® 8 is not supported on your board.

http://www.intel.com/support/motherboards/desktop/sb/CS-008326.htm Desktop Boards — Supported Operating Systems

Allan.

BVarg2
Beginner
571 Views

So if I get it right:

 

Is UEFI not supported in Windows 10 (or Windows 8) by this board?

The strange thing is, If I switch the drive configuration to configure SATA as IDE, then Windwos 10 installs in UEFI mode without any problem.

 

But if I switch to AHCI the Recovery BSOD comes up and stop the OS from booting.

Windows 7 with MBR, AHCI and BIOS

Windows 7 with GPT, AHCI and UEFI

Windows 10 with MBR, AHCI and BIOS

Windows 10 with GPT, AHCI UEFI

BUT

Windows 10 with GPT, Native/IDE UEFI

 

WHY?

Allan_J_Intel1
Employee
571 Views

The board you have does not provide BIOS or driver support for Windows® 10, you need to stick with a supported operating system http://www.intel.com/support/motherboards/desktop/sb/CS-008326.htm Desktop Boards — Supported Operating Systems

Allan.

BMoor7
Beginner
571 Views

I was able to get Windows 8.1 installed using the latest bios, AHCI and UEFI boot. Seems to be working fine so far.

Reply