Intel® Desktop Boards
Peer-to-peer support only
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11453 Discussions

DH61CR Bricked After 99 BIOS Update


In the organization I work for we have quite a handful of Nexlink PCs that have the Intel DH61CR, on Core i3-2100 CPUs. They are very slow until we update them to BIOS version 120. Since they ship with version 23 the process is to iFlash or Express update them to 48, then to 99, and after that we have to use the recovery mode (pulling the BIOS Config jumper and battery, with the BE0120.BIO on a flash drive and then normally it will flash to 120.

This process works on the vast majority of computers we've done it on. But here's the issue. On a few of the computers, the 99 update will render them completely useless. Following normal protocol I will pull the battery and jumper out, then plug the computer back in after 30 seconds, then power it on, these few computers won't even wake the monitor. The only sign of life is the activity light on the flash drive. It will flash for about 15-20 seconds, then it will stop, then repeat with the flashing intervals, while the monitor is still off. I've tried putting the jumper back and using F7 to flash as well and it just freezes up when I press enter on the prompt to confirm the flash. I've also tried bridging the 2nd and 3rd pins on the BIOS Config jumper and I just get a BIOS maintenance window. The computer won't boot or reflash it's BIOS.

Is there any other suggestions to get these machines working again?

0 Kudos
1 Reply

After BIOS update if the board does not do anything, the only way to get the board back to life would be, BIOS recovery. Removing the jumper and downloading the .BIO file off Drivers & Software and placing the file onto an USB flash drive, the motherboard should be able to read the USB port.