Intel® Desktop Boards
Peer-to-peer support only

DH67BL no start


I have an Intel Dh67BL AA=G10189-210 that would not run! No sound, no video, I tried another mobo, and get the same results. I then tried another processor, and now I get a memory error. Old processor i5-2328, new processori5-3570.

Do not know what to do from here!

0 Kudos
1 Reply
Super User Retired Employee


Let's start at the beginning. What happened? The system was working fine and then... what? Or is this a new build with a recently acquired (used) board?

When you plug the system into an A/C source - but haven't yet pressed the power button - is the (green) Standby LED on the board lit up? If not, look to there being a power supply problem. Otherwise, what then happens when you press the power button? Do the fans start spinning (especially that on the processor)? Is the Power LED being lit up?

The DH67BL board must initially be presumed to support only 2nd generation Intel Core processors (and Pentium/Celeron equivalents). Only after the BIOS has been upgraded beyond a specific version can it be presumed to support 3rd generation processors. Thus, you must power up with the i5-2328 and ensure that the BIOS has been upgraded before you can power up with the i5-3570. The BIOS upgrade process is described here: Updating the BIOS to Support 3rd Generation Intel Core Processors.

Hope this helps,