Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DKEBeck88
New Contributor I
1,707 Views

DH67CL cannot boot into BIOS after BIOS upgrade to ver.163

On a DH67CL, I tried updating the BIOS from version 105 to 163 using the F7 method off of a USB drive. I was not having any problems at all with my PC, but I wanted the microcode update for the various Spectre vulnerabilities. All of the messaging during the upgrade process was good. After the update, the computer rebooted but just to a blank screen. Power was on, fan was on, etc., but the monitors never went back on, and the keyboard was unresponsive. No POST error beeps or anything like that. I tried rebooting a few times but never made it any further.

 

I attempted many recovery suggestions. I removed the graphics card and attempted to use the onboard video. I unplugged my second hard drive (power and data) and CD ROM so the only device remaining is the boot drive, but no good. I removed the BIOS jumper and attempted to recover BIOS via USB, but I could never get anything to show up on the screen as it isn't getting that far.

 

I removed the battery for 15 minutes or so in order to clear CMOS. I know that it did...something...because after I did that, plugging the power cable in to the PC didn't immediately turn on the computer like it used to - I had to then push the power on button to start up the PC. So it does seem that the settings were reset. But unfortunately, no improvements. PC still turns on but doesn't even make it to anything displaying on the monitor.

 

FYI, this is the same issue that is described here:

https://forums.intel.com/s/question/0D50P00004QxvgISAR/board-dh67cl-cannot-boot-into-bios-after-bios...

 

I apologize if it was inappropriate for me to both respond to that post and create a new one. In looking at that thread, there was a link to what is probably the "correct" way to have done what I wanted to do (looks like I should have done a few intermediate upgrades, maybe?). Unfortunately at this point it's too late for that.

 

I saw that I can buy a BIOS chip online, but I'm pretty sure this chip is soldered in and that's beyond my capabilities. I can also buy a used replacement motherboard online as well, which is probably something I can handle - although first I want to see if there are any suggestions to salvage what I have.

 

Anyone have any ideas?

0 Kudos
7 Replies
AlHill
Super User
1,203 Views

Do NOT buy a bios chip online, or from any other source.

 

Have you tried the recovery method?

https://www.intel.com/content/www/us/en/support/articles/000005630/boards-and-kits.html

 

Doc

 

 

DKEBeck88
New Contributor I
1,203 Views

Thanks - definitely won't buy a BIOS chip!

 

I did try that recovery method. And I tried it again just now via n.scott.pearson's steps. I'll post a reply to his answer with details.

n_scott_pearson
Super User Retired Employee
1,203 Views

First of all, every user's problem is unique. You have different processor, different memory, different initial BIOS version, different initial BIOS configuration, etc. and etc. Always report your problem using a new question. It is ok to reference that other question but do not assume that it is the same problem; it may not be (though, in this case, I don't think so).

 

Jumping from BIOS 105 to BIOS 163 is a problem. Did you not read the release notes before attempting this? You needed to first upgrade to BIOS 132 and then 163. Regardless, you are where you are. The only path to recovery from this state is via the BIOS Recovery process. You may be able to reinstall BIOS 163 using the BIOS Recovery method or you may need to install BIOS 132 via BIOS Recovery and then upgrade to 163.

 

The BIOS Recovery process has its issues and your attempts may have failed for a different reason than you think. The tiny Recovery BIOS included with the main BIOS does not have the same level of compatibility with flash disks that the BIOS (or Windows) does. I recommend that you do the following:

 

  1. Use a USB 2.0 flash disk. Do not use USB 3.0 flash disks.
  2. Use a relatively small flash disk. Large flash disks can be problematic.
  3. On another Windows-based PC, reform this flash drive, using the FAT32 file system, with (very important!) the Quick Format option disabled. Do not use Linux- or MACOS-based PC. Do not use any file system but FAT32. If FAT32 is not offered as a choice, your flash disk is too big. There is no need to make the flash disk bootable.
  4. Copy the .BIO file desired into the root folder of the flash disk. There should only be one .BIO file on the flash disk. The name of this file does not matter; use the name it came with.
  5. Do not forget to properly eject the flash disk; don't just yank it out.
  6. Plus the flash disk into one of the (black) USB 2.0 ports on the back panel of the board. Do not use (blue or orange) USB 3.0 ports. Do not use front panel USB ports of any kind.
  7. When you power on with the BIOS Configuration jumper removed, to process should start automatically and, if it has one, you should see the access LED on the flash disk flashing. If you see no output on the monitor, this doesn't mean that the process is not working. Wait 15 minutes before powering off in this case.
  8. I always recommend you clear CMOS before doing BIOS Recovery. Remove A/C power and then remove the CR2032 battery for a full 15 minutes.

 

Hope this helps; let us know...

...S

DKEBeck88
New Contributor I
1,203 Views

Thanks for the reply! I did read the release notes and the installation readme, and didn't see anything saying that I couldn't upgrade right to 163. I saw a few warnings that once I went to 151 I couldn't go back, but nothing saying I had to get to 132. I've attached the release notes I was going off of. You are correct that it doesn't really matter since I am where I am, but I would like to learn where I went wrong and what I missed for the future.

 

Anyway, I followed your steps exactly this time. When I originally tried the fateful upgrade, I did have a relatively small USB drive (8GB) and I did format it to FAT32, but I did it on Linux and it definitely didn't take very long at all to format before it was done. And I also used a top access USB port instead of one of the back ports (but it was definitely a USB 2.0 port). This time I used a 1GB USB 2.0 drive, formatted it (NOT the quick format) on a Windows 10 machine, copied just one .BIO file to it, and ejected it properly. I removed the BIOS jumper and removed the battery and waited for 15 minutes. Then I put the battery back in, but the USB drive in one of the USB 2.0 black back ports, and attempted the recovery. Unfortunately, it did not work. Same results -the monitor didn't turn on or even acknowledge that the machine was doing anything. I waited 15 minutes before manually turning off the power, but putting the jumper back to normal and starting up again resulted in the same issue. I did this with both the 163 and 132 .bio files (formatting the USB and clearing CMOS each time between attempts) with no luck.

 

Do you see anything in my rundown that I did wrong? If not, any other ideas?

n_scott_pearson
Super User Retired Employee
1,203 Views

I wouldn't say that you did something wrong, per se. These are my words of wisdom, from 18 years as a member of this organization and from many years working on BIOS features and releases for both Desktop Board and NUC products:

 

  1. Any time that you see a note indicating that a BIOS introduces a security, structural or architectural change that you cannot downgrade past, it is best to step into this change without adding any additional changes into the mix. That is, install this particular BIOS release on its own; don't jump directly to some subsequent release.
  2. If your current BIOS is some distance below this BIOS, it is recommended that you install up to this BIOS before installing it. In this case, BIOS 132 is the release just prior to BIOS 151, which introduced the security, structural or architectural change.
  3. On the newer NUCs, a revamped version of the facility for installing BIOS releases from Windows was released. You can trust it. For the early (3rd and 4th generation) NUCs and for all of the Desktop Boards, however, I do not at all trust the previous version of this facility that supported them. I have seen it completely brick boards on a number of occasions. This was reported to the BIOS team on a number of occasions, but the issue is so sporadic in its occurrence that they were never unable to reproduce it (you can't fix what you can't reproduce). Bottom line, unless you absolutely have to (i.e. machine is remote and costly to get to), stay away from the Windows Express BIOS Update (EBU) facility. Stick with F7 or iFlash updating. Better yet, always use the BIOS Recovery process.

 

Regarding the BIOS Recovery process,

 

  1. 8GB flash drives are just fine; it is the 64GB and larger flash drives that I was referring to.
  2. You must use FAT32. The vFAT, exFAT, etc. (and etc. and etc.) versions are not 100% compatible with the Recovery BIOS. Similarly, while the Linux pundits claim that the FAT32 formatting capability on Linux is 100% compatible, it simply isn't. I am not interested in arguing this with anyone. It is a fact, not an opinion. Use a Windows-based PC for your formatting operations.
  3. It is an absolute must that you reformat each flash drive, at least once, with the Quick Format option disabled. Most of the bulk/gang processing tools used by the flash drive manufacturers are Linux based and there is some difference in what they do that creates an incompatibility. To be honest, we never figured out exactly what was causing this. We found (purely by accident) that doing a long format operation gets rid of this incompatibility. Sorry this operation takes so long with USB 2.0 and older drives (at least you only have to do it once).
  4. My recommendation (ask) to not use front panel USB ports is simply because they introduce additional variables into the process. There is a connector on the board that could become dislodged, a ribbon cable that could get damaged, interfered with, etc.

 

Ok, to your issue. It looks like you did what you should. I am at a loss to identify what to do differently. It may be bricked. If you want to try some extraordinary steps, you can try,

 

  1. Replace the CR2032 battery with a new one. These batteries do run out of charge eventually.
  2. Reduce down to a single DIMM and try this DIMM in the various sockets. Issues with memory initialization can cause the Recovery process to abort itself; the Recovery BIOS does not have as-sophisticated a retry algorithm.

 

That's it. Let me know how it goes...

...S

DKEBeck88
New Contributor I
1,203 Views

Thank you so much for your detailed reply. It is very interesting and informative.

 

I ended up buying an exact replacement DH67CL from a reputable eBay seller. I just installed it and it worked perfectly.

 

It arrived with BIOS version 146 (BLH6710H.86A.0146.2011.1222.1215, to be exact) - so newer than the version I had on my bricked original mobo, but not the newest. What's extra confusing is that version 146 isn't even listed in the 163 release notes - it jumps right from 132 to 151. Is this some sort of unofficial version? Or perhaps the release notes for 163 don't list every version?

 

I'm pretty sure that I'm not going to press my luck by trying to upgrade this new mobo BIOS to 163 (even though I really would like the Spectre fix), but in case I do work up the courage, what is your suggestion for the best path forward? Use the recovery method (and your best practices regarding USB format, port, etc) and go right to 163? Or is there an intermediate step you'd recommend?

n_scott_pearson
Super User Retired Employee
1,203 Views

They sometimes ​release a BIOS to the factory but do not post it for download. Don't worry about it. Since this is past the pivot BIOS (132), go ahead and upgrade to the latest -- but recommend you use BIOS Recovery process to so so.

...S

Reply