Intel® Desktop Boards
Peer-to-peer support only
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11453 Discussions

DH67CL no video during boot

idata
Community Manager
1,680 Views

I finally got my DH67CL (h67 chipset) onboard video working with dual screens in Windows 7.

Then I booted and ran a Fedora12 live CD and that went fine (have Win7 64bit installed).

After booting the fedora cd, now whenever I reboot, I don't see any video until the "starting windows" screen appears.

I don't see the Intel bios splash screen ("Press F2...., etc.") in other words.

I tried unplugging the 2nd monitor, and I tried booting with the DVI connected with an adapter to the analog vga input on one of my monitors. Neither worked.

The system boots into Windows 7 just fine, though. I just can't use the bios menu anymore (because I can't see anything).

While trying to get dual screens to work, I updated the bios to BLH6710H.86A.

Am I supposed to downgrade the bios? Or wait for a new one? Any other suggestions please?

My cpu is an i7-2600k if that matters.

0 Kudos
8 Replies
yf38
New Contributor II
234 Views

Hi,

Have a look at the 3 pins connector with a jumper set to "normal" position and just change it to the opposite side to get "configuration" position.

When in this position you reach the bios after power up without any action to do.

This 3 pin jumper is close sata1 connector, it is documented on the configuration label.

idata
Community Manager
234 Views

I don't want to sound lazy, but I didn't try it.

 

 

The reason is that I think setting the maintenance mode jumper

 

position is for getting you into the bios if you lost the bios

 

password.

 

 

My problem isnt't that I can't get into the bios. If I press F2 at

 

the start of booting, it doesn't continue to boot. So I think I must

 

be at the bios menu, I just can't see it.

 

 

I think somehow it maybe got set to always use the hdmi during post.

 

Either I did it by accident (I was careful not to change it from auto

 

detect though), or maybe the probing Fedora12 did during boot caused

 

it to change.

 

 

I was never able to get it to display over hdmi during post before

 

(even if only hdmi was connected), but I was able to get dual screens

 

working in windows.

 

 

I think maybe my best bet to get the display back during post would be

 

to clear cmos.

 

 

The problem with that is that I think changing the video memory size

 

from "maximum" to 256MB may have been necessary to get dual screens to

 

work in windows.

 

 

My theory is that the bios does not correctly initialize the hdmi port

 

for my monitor, so if it's set to "use maximum" it doesn't detect the

 

monitor, so it allocates only enough memory for one display, and

 

subsequently only one display can be used in windows. I think when I

 

set it to use 256MB, it always allocates enough for two screens, so

 

then the display driver tries to initialize the hdmi port and it sees

 

the 2nd monitor then.

 

 

So my fear is that if I clear cmos, then if I still can't see the

 

display during post, I won't be able to change it from "use maximum"

 

(which I think is really "auto") to "use 256MB" for video memory, and

 

I won't be able to get dual screens working again.

 

 

So, I think I'll just cross the bridge when I come to it (try to make

 

it work when I actually have to change something in bios).

 

 

I'll try the next bios update too.
idata
Community Manager
234 Views

I installed the new bios update (installed it from Windows)

BIOS Update [BLH6710H.86A]

Date 4/15/2011

Version 0110

And now I have video during post/boot and can use the bios setup menu again.

The video now displays on both monitors during boot.

Dual screens in Windows are still working.

The update reset the video memory size to "maximum" and it still works (I had changed it to 256MB before when I was getting dual screens to work in Windows).

idata
Community Manager
234 Views

plz help i jus got the same motherboard but i cant see the bios or anything on single or dual screen. i have no clue wat to do plz help somebody.

idata
Community Manager
234 Views

try reseating the CPU, RAM, power supply cabel..

remember plug in the 12V ATX 4 pins power supply cable.

idata
Community Manager
234 Views

i did as you said but still nothing on screen . The motherboard light , case fans are all working as usual. there is a bios cfg 3 pin on which thiere is a yellow two pin connector ( m not sure abt the exact name) which is conncted from right side which leaves a free pin on left side. i tried changing this connector around but no difference.

idata
Community Manager
234 Views

it was a fualty ram after replacing it with kingston the bios showed up and was able to install windows thanks all.

IUman
Honored Contributor II
234 Views

Good to hear that your issue has been resolved and thank you for letting us know.

Regards,

Ivan

Reply