Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
972 Views

DH77DF BSOD: driver power state failure, 0x9F; USB & ethernet ports turning off

Hi all --

My first post on this forum so hopefully I give enough info to help solve my problem.

I just upgraded my HTPC and so built my first Windows 7 PC (never had a need to upgrade from XP, believe it or not). So far I am quite impressed but I am having a number of issues with power management. I'd love some help tying all these together so I'll start at the beginning.

I've had the machine running for two weeks now. It's an Intel DH77DF mobo, all the newest drivers on it, fresh from Intel's site. At first I noticed the keyboard would become unresponsive after a while -- not even the lights for caps/num lock would turn on (MS Wired Keyboard 600). So I figured it was shutting off the USB ports and so I went into Device Manager and hit the properties for all USB ports and unchecked allowing Windows to shut them off to save power. I then went to power management and turned it on to maximum performance.

Next morning, I wake up and go to hit the PC to put on some music and the keyboard is unresponsive again. (Aside: I have two keyboards connected, the MS one mentioned earlier and a Logitech diNovo Mini for HTPC stuff. There's also an old MS wired mouse attached (which has never lost power, oddly enough).) I restart to bring the keyboard back around -- because unplugging it and putting it in any USB port won't bring it back -- and when I restart, it takes FOREVER. I'm talking 15-20 minutes (when boot after POST takes like 30 seconds). The restart eventually craps out to a BSOD: power driver state failure, error code 0x9F.

So I researched that error and most of the advice seems to come to "run sfc \scannow" (done, more than once, no issues) and "update your drivers" (already done). I looked in the event viewer for evidence of that crash but don't think I found anything.

I found a page on a registry entry you can make for disabling selective suspend in USB completely, and I've done that, and it says it's disabled under the advanced settings in power management, but, I dunno...my peripherals still die.

I updated my BIOS last night, as I saw the new version said something about USB ports...nope, they still were dead when I woke up this morning.

Checking everything, I don't think it's a power/clock issue, as I ran prime95 and OTPC last night to stress test it and watched the voltage and temps through Intel Desktop Utilities and nothing was out of the ordinary (though this machine does run warmer than I am used, but the temp " gauges" are all green according to Intel).

As a final clue, I noticed something during yesterday morning's restart. I had my work laptop on and it's a Mac, and Finder always shows the devices on the network. During the long shutdown that goes to bluescreen, the HTPC is not on the network before restart, comes on to to the network several minutes into the long shutdown, hangs out on the network for a few minutes, disappears, and then BSOD about a minute after that. It's not just USB shutting down, I guess (if I had a SATA device I'd test that too).

OK, sorry about the long post and all the parentheticals, just wanted to make sure I gave as much pertinent info as possible. I'd be very grateful if someone had any clues. If this is in the wrong forum and should be under the BSOD forum, let me know and I will close this and repost.

Thanks very much for reading --

Micah

Tags (1)
0 Kudos
5 Replies
MJans6
New Contributor I
58 Views

Hi Micah,

Just to let you and everyone else here know. I suffer from the dead USB ports too! and occasional BSOD and sometimes a freeze with the Ethernet port taking down my whole LAN, my router is taken down.. never ever have I experienced such Voodoo!

My front USB ports won't detect my wired USB keyboard too. When re-plugging into the back high-current USB 2.0 ports it get's detected. So far this mobo has been a friggin nightmare for my HTPC setup. Doing a complete re-install tonight (Windows 7 x64) this time enabling the Intel ® Rapid Start Technology.

I must mention I have a HDMI-CEC internal and a CIR receiver module connected to the appropriate headers.

idata
Community Manager
58 Views

Hello --

It sounds like we have similar problems. I have never experienced any LAN issues beyond my ethernet port dropping connection with the USB, however.

Let me know if the re-install with the Rapid Start helps -- I don't know what that is, so I don't know if I enabled that or not.

Micah

idata
Community Manager
58 Views

Hello:

 

 

Thank you very much to all the peers on this thread for the information provided.

 

 

To Micah Stupak:

 

 

Thank you very much for providing all the information above, it is actually really helpful for us to better assist you to get all the details as possible about the issue.

 

 

In regards to troubleshoot steps to try, basically you tried everything that we recommend, based on that, I wanted to check if the link provided above fixed the problem or if the problem with the USB and getting BSOD still persists?

 

 

Just to make sure, what is the BIOS version currently on the board?

 

 

Do you see any question or exclamation marks on device manager on USB devices?

 

 

On the following link you will find all the drivers for your board for Windows® 7:

 

 

https://downloadcenter.intel.com/product/59503/Intel-Desktop-Board-DH77DF https://downloadcenter.intel.com/product/59503/Intel-Desktop-Board-DH77DF

 

 

Now, to re-install Windows® from scratch is always that we recommend once you tried all the troubleshoot steps, so, that might help.

 

 

Re-installing Windows® enabling Intel® Rapid Start Technology is an option that you can always try, but it does not seemed to be related to that feature, the USB should work just fine without that feature, and the same thing goes to the BSOD.

 

 

Please let me know the results of trying the link provided above by kinjo23.

 

 

Any questions, please let me know.

 

 

Alberto
idata
Community Manager
58 Views

Hello Micah Stupak:

 

 

I just wanted to check if the problem with the Ethernet ports was fixed or if it still persists?

 

 

Also, we wanted to know if you need further assistance on this matter.

 

 

Any questions, please let me know.

 

 

Alberto

 

kbeti
Beginner
58 Views

Reply