Intel® Desktop Boards
Peer-to-peer support only
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11460 Discussions

DH77DF - Raid controller only initialised on cold boot

Community Manager

I've got a DH77DF with an Adaptec 6805E and the Adaptec RAID BIOS (Latest - V5.2-0 [Build 19109]) ONLY loads when the PC is cold booted (i.e turned on from an off state).

If you restart the PC - after a bios change, or from withing the operating system the Adaptec RAID BIOS never loads, and my storage drives disappear. You have to turn off, then turn back on to get your drives back.

A couple of thing to note:

If I cold boot then enter the BIOS PCIE the settings registers the RAID controller correctly:

Slot 7 PCIe x16 Using x4 Speed 2.5 GT/s

PCIE Vendor ID:Device ID <9005:028B>

If you enter the Intel BIOS after a restart, the PCIE settings does not register the RAID controller:

Slot 7 PCIe x16 Not Populated

I've set the Hard disk Pre-Delay to every available value. This has had no effect. It's currently set at 10 seconds.

A related issue (that's probably Adaptec and not Intel) - you need at least 1 array defined for the Adaptec BIOS to install correctly - if you have all JBOD's, you get the message "NO LOGICAL DRIVES FOUND - BIOS NOT INSTALLED" after the RAID controller Configuration utility runs. The operating system still sees your drives, but ONLY on a cold boot.

This all leads me to suggest that the INTEL DH77DF isn't initializing the PCIe controller on restart, only on cold boot. I'd call this a bug, with a severe impact, especially on a headless server. Can we get a fix please?

I'm sure someone will ask, so here's what I'm running:

Intel DH77DF mobo. flashed to latest BIOS (0105 @ 12/13/2012 )

Intel Core i7-3770T Processor

Corsair XMS3, 8GB Matched Pair, DDR3, 1600 MHz memory

150 Watt DC-DC Power Converter (picoPSU-150-XT)

150 Watt 12 Volt AC Power Adapter

Adaptec 6805E RAID Controller flashed to latest BIOS (V5.2-0 [Build 19109])

Hard drives on mobo:

1x Intel 520 Series 120GB 2.5" SSD (SATA 0 on mobo)

Hard drives on Adaptec RAID Controller

2x Western Digital Scorpio Black WD7500BPKT 2.5" 750GB 16MB 7200RPM

2x Western Digital Scorpio Blue WD10JPVT 2.5" 1TB 8MB 5400RPM

0 Kudos
2 Replies
Community Manager

Quick update:

I pulled the Adaptec 6805E and tried a HighPoint RocketRAID 2300 controller I had (brief) access to. Once I installed the storage controller drivers in Windows 8, the HighPoint worked flawlessly and as expected. The HighPoint BIOS loaded every time, whether from reboot or cold boot.

Community Manager

Installing BIOS update 1006 (KC0106 - 2012-12-27) resolved this issue for me.