Intel® Desktop Boards
Peer-to-peer support only
11435 Discussions

DH77EB Mainboard Management Engine Lost

Raw0093
Beginner
834 Views

IMG_20210228_094339~01 - 副本.jpg2021-03-11_095041.jpg

Can anyone guide me recover "ME"?

 

0 Kudos
8 Replies
n_scott_pearson
Super User Retired Employee
821 Views

If there is any chance of recovery, you would do so by installing (or reinstalling, as the case may be) the latest BIOS package using the BIOS Recovery process. This is documented here: Intel Desktop Boards BIOS Recovery Instructions.

To help you better, here are my handy-dandy, step-by-step instructions for BIOS Recovery:

  1. NOTE: Read these instructions completely before starting. Follow all instructions EXACTLY.
  2. On some other Windows-based PC, make sure that you have the .BIO file for the BIOS release you wish to install.
  3. Insert a 32GB or smaller (the smaller the better) USB 2.0 flash drive into the PC. Do not use USB 3.0 flash drives (many are not compatible). It is also best if you use a flash drive that has an access LED that you can watch.
  4. Format this USB flash drive using the Windows Format applet. Select to install the FAT32 file system (NOT vFAT, NOT exFAT; FAT32 only). You must also specify that the Quick Format option be Disabled (unchecked).
  5. NOTE: If FAT32 is not offered as a choice by the Format applet, your flash drive is too big; use another.
  6. Copy the .BIO file into the root folder of this USB flash drive. This should be the only .BIO file in the root folder of the USB flash drive.
  7. Properly eject the USB flash drive. Do not just yank it out. Do this from File Explorer or using the Safely Remove Hardware and Eject Media System Tray applet.
  8. Power off the Desktop Board system.
  9. Remove the yellow BIOS Configuration jumper from the board. It will be the only yellow jumper; the rest will usually be black.
  10. NOTE: Remember the pins that this jumper was plugged onto; you will need this information later.
  11. Plug the USB flash drive into one of the black USB 2.0 ports on the back panel of the board. Do not use blue or yellow USB 3.0 ports. Do not use any front panel USB ports.
  12. Power on the system.
  13. The BIOS Recovery process should start automatically. You should see a progress report on your main monitor.
  14. NOTE: If you do not see a progress report displayed on a monitor, do not power off the system for at least 15 minutes. While it is rare, it is possible for the process to proceed without an onscreen display; you must give it ample time to complete, just in case.
  15. When the BIOS Recovery process is complete, you will be asked to power off the system. Do so.
  16. Restore the yellow BIOS Configuration jumper to the pins it was on previously. This should be across pins 1 and 2 of this (three pin) header.
  17. Remove the USB flash drive from the back panel of the board.
  18. Power on the board.
  19. Immediately begin pressing the F2 key, over and over (approx. once per second) until you see the BIOS Setup (or Visual BIOS) screen displayed.
  20. Verify, using the BIOS version string, that the BIOS installed properly. Stop if it isn't.
  21. Verify, using the Additional System Information scene, that the ME firmware revision is not 0.0.0.0 and is not blank. Stop if either of these is the case.
  22. Press the F9 key (followed by the Y key) to reset of the BIOS configuration.
  23. Press the F10 key (followed by the Y key) to save the BIOS Configuration and exit BIOS Setup.
  24. Once screen is cleared (goes black), begin pressing the F2 key, over and over, until you see the BIOS Setup screen displayed.
  25. Make any changes to the BIOS configuration that you desire (for example, disabling NUMLOCK) or that you require (for example, setting Boot Order, enabling UEFI, etc.).
  26. Press the F10 key (followed by the Y key) to save the BIOS Configuration and exit BIOS Setup.
  27. Test.

Hope this helps,

...S

Raw0093
Beginner
816 Views

IMG_20210311_163948~01.jpg

  Unfortunately, I according to your steps to operate, but nothing happened.Port of USB2.0 behind don't read.I upgrade by using the method of "F7",from EB0053 upgrade to EB0093, I think because EB0093. BIO file without the management engine inside 。

  I can't from EB0093 upgrade to EB0103,I think it's Management Engine lost causes.I would like to how to restore Management Engine。

n_scott_pearson
Super User Retired Employee
790 Views
There is ME F/W in every BIO file and nothing is installed if the ME F/W install fails. No, this is the unfortunate result of "jumping too far" -- meaning too much happened between your original BIO and the later BIO. You should have installed the following BIO files in this order: 62, 71, 89, 96, 98, 103.
I have documented this - and provided the set of BIO files - in a couple of conversions here. I am away from home right now and this mobile interface sucks (because of my small screen size) and this makes it very difficult to look up this guidance now (I will do so once back in my office).
So, what to do? First of all, we must get BIOS Recovery working as this is now the only way to get the ME F/W rewritten. Try different USB flash drives (the smaller the better). Though I usually don't recommend it, try using rear panel USB 3.0 port or even front panel USB 2.0/3.0 port. Do not forget that the full reformatting step is an absolute must (the bulk formatters the manufacturers use cause compatibility issues at the sector level because Linux based).
Hope this helps,
...S
Raw0093
Beginner
775 Views

My U disk capacity is very small(the smaller the better).I tried many times, the BIOS recovery is still not working.

USB Disk.jpg2021-03-12_083038.jpg

Raw0093
Beginner
773 Views

I also try to use Intel (R) the Firmware Update Utility such tools to restore my ME, but still failed.

2021-03-12_084421.jpg

n_scott_pearson
Super User Retired Employee
700 Views

The only method for recovering the ME F/W is using the BIOS Recovery process. The yellow BIOS Configuration jumper that you are removing enables support for the BIOS to write the ME F/W itself. In all other cases, the ME must be operational for the ME to be upgraded because the ME performs the write operations.

Bottom line, you must get BIOS Recovery working.

...S

Raw0093
Beginner
640 Views

Thank you for your advice, but how to do to make the BIOS Recovery working normal?

n_scott_pearson
Super User Retired Employee
631 Views

Follow the process I have described in detail above. If the BIOS Recovery doesn't seem to start (you don't see output on monitor), switch to a different USB flash disk. Remember, no USB 3.x flash disks, nothing larger that 32GB, you must do the reformatting with Quick Format disabled and the .BIO file should be the only thing on the flash card.

...S

Reply