Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DEdwa3
New Contributor I
1,044 Views

DH87RL RAID "Question value mismatch with Option value!"

DH87RL with BIOS version 0322 UEFI

Intel Rapid Storage Technology 12.8.0.1016

I have installed Windows 8.1 with the SATA mode set to RAID. Using an mSATA SSD I am trying to configure acceleration. Unfortunately Intel Rapid Storage Technology will not allow me to accelerate my system volume on the HDD. Diskpart shows no partitions on the SSD. I noticed I receive the error "Question value mismatch with Option value!" when selecting to create a RAID volume. It says to press Enter but doing so displays the error again and I must restart the system. None of my disks are members of a RAID array. Why am I not able to accelerate using my SSD? What does the error I reference mean? A Google search turns up nine results mainly related to Linux. Could this error be related to my issue?

Tags (1)
0 Kudos
1 Reply
DEdwa3
New Contributor I
89 Views

So after hours of testing I was able to get my Rapid Storage to accelerate my HDD. Of the many things I tried, this one I found deep in some blog post.

The way I got things working.

  1. Install operating system - Reboot
  2. Update operating system - Reboot
  3. Install chipset drivers
  4. Install Rapid Storage Technology - Reboot

My OS install was standard. I did blow away the logical volumes to start fresh. No RAID arrays configured to this point. Keep in mind the SSD must have no partitions. I left my SSD in an uninitialized state. To do that you can use diskpart > select disk X > clean all.

So once the steps above are performed open up Rapid Storage, and then Disk Management. I had no acceleration options. I then shrank my system volume (C:\) by 1024MB. When I went back to Rapid Storage and press Rescan I can now accelerate the volume.

The next part is that I went back to extend the volume after acceleration was enabled.

Before Shrink: 1999844143104B = 1907199.99609375MB

After Shrink: 1998770401280B = 1906175.99609375MB

After Extend: 1999839948736B = 1907195.99603272MB

Difference: 0000004.00006103MB

As you can see above there is 4MB missing after I enabled acceleration. I assume this is for storing RAID configuration data on each volume. I would like someone to confirm.

Going back to the error in the title of this post I still am unable to create a RAID volume in vBIOS when none exist. I get the same error even after blowing away my RAID config. However when Rapid Storage enabled acceleration I can now go into the BIOS and at least look at the disks. There is no create/modify/delete from the BIOS which would be nice to have.

Hopefully this information is useful to someone. I still would like to know what the error means. Let me know of any questions.