Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,398 Views

DH87RL USB 3.0 back panel connectors

Jump to solution

Hi,

I have installed a new DH87RL lately. Everything works fine except the back panel usb connectors: My external usb 3.0 hard drive does not connect with superspeed, although I connected it to the back panel connectors. Seems like the back panel ports are running usb 2.0 only:

Is this a known problem or a configuration issue?

Thanks in advance for any hints.

Michaelusb 3.0

Tags (1)
0 Kudos

Accepted Solutions
Highlighted
14 Views

djONz, for this kind of behavior I will recommend you to check if you are running the latest BIOS available for this motherboard.

 

This is the latest USB 3.0 driver https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22589&lang=eng&OSVersion=%0A%09%09%0...

 

If you connect the USB 3.0 hard drive on the ports located at the front of the board, which is the behavior?

Which is the AA# of your motherboard?

View solution in original post

0 Kudos
3 Replies
Highlighted
15 Views

djONz, for this kind of behavior I will recommend you to check if you are running the latest BIOS available for this motherboard.

 

This is the latest USB 3.0 driver https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=22589&lang=eng&OSVersion=%0A%09%09%0...

 

If you connect the USB 3.0 hard drive on the ports located at the front of the board, which is the behavior?

Which is the AA# of your motherboard?

View solution in original post

0 Kudos
Highlighted
Beginner
14 Views

Sylvia,

Problem solved. I didn't think of the most obvious. Shame on me...

Thanks a lot!

Michael

0 Kudos
Highlighted
14 Views

No problem Michael!! I'm really glad to know your system is working now.

0 Kudos