Community
cancel
Showing results for 
Search instead for 
Did you mean: 
FThak
Beginner
1,829 Views

DH87RL: Wrong clock multipliers with Core i7 4770

Hello,

I have the Intel board DH87RL and the Intel Core i7 4770 CPU (3,4 GHz, turbo max 3,90 GHz).

BIOS version is latest 0324.

I activated speedstep and turbo boost.

The BIOS shows wrong clock multipliers. the multiplier is set to x32 in general and to x32 (one core), x31 (2 and 3 cores), x30 (4 cores).

I cannot adjust these settings. It is not enabled for editing.

The correct clock multiplier for one core in turbo mode should normally be x39.

Furthermore the Windows Task manager (Windows 8.1 Pro 64 bit) shows a maximum speed of 3,00 GHz.

If i run prime95 or IntelBurnTest with one or 2 threads, I will get a speed (displayed in TaskManager) of 3,4 or 3,66 GHz (it changes). But I don't know if i can trust these numbers.

CPUz shows correct clock multiplier range, but the highest used was a multiplier of x37 resulting in a speed of 3,69xx GHz.

I could make photos of the BIOS settings and upload here, when it helps.

Does anyone have an idea whats going wrong here and how i could fix it?

0 Kudos
4 Replies
FThak
Beginner
111 Views

here are photos of the BIOS settings.

As you can see, the clock multiplier are totally wrong for the i7 4770 CPU.

Silvia_L_Intel1
Employee
111 Views

When Turbo Boost is enabled, the highest your processor could go is to 3.9GHz. There are not other settings you can change since this is not an unlocked processor.

The Intel® Turbo Boost technology feature is auto-managed by the processor having a balance between the power consumption and the chip heat.

The maximum Turbo Boost speed won't be reached by all of the processor cores at the same time, the value is assigned to the cores being used gradually at the moment the Turbo Boost kicks out so it is possible that only one core reaches the maximum Turbo Boost speed assigned by default.

Intel® has a tool that will test every single component inside the processor and then will generate a report. I recommend you running the tool named Intel® Processor Diagnostics Tool. It can be downloaded at the following link: https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=19792&lang=eng&OSVersion=Windows%207... https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=19792&lang=eng&OSVersion=Windows%207...

FThak
Beginner
111 Views

Thank you, Sylvia, for your reply!

Yes, I know the facts about the Turbo Boost technology. That is the reason why i am only testing with one or two threads running at the same time.

I solved the wrong set clock multipliers by myself. I did the following:

1.) Remove CMOS battery.

2.) Remove secure jumper for "reset". (dont know if this was necessary)

3.) Boot into BIOS

4.) Wondering about a set clock multiplier of 0 (0 GHz would be funny)

5.) Loading BIOS defaults

6.) Seeing the correct set clock multiplier of 39, which will result in 3,9 GHz with turbo

 

7.) Found a bug: I could overlclock the integrated GPU (but i didnt). Now the setting is locked again.

Still with prime95 and IntelBurnTest I dont get 3,9 GHz.

But with the Processor diagnostic tool i get. Hmmm....????

Silvia_L_Intel1
Employee
111 Views

Excellent!! I'm glad to know you were able to solve your issue.

Reply