Intel® Desktop Boards
Peer-to-peer support only
11478 Discussions

DH87RL not recovering BIOS


Good day, fellow DH87RL owners.


I bought a DH87RL a 18 months ago, had Windows 7 running for 17 of those months, and then it stopped working.

The board was just replaced (thank you Intel), got it back on Monday (2015-07-27).



Now the new board is giving me grief.

I wish to install Windows 8.1 UEFI onto an SSD that I know works with RAM that I know works (used both until Monday on DH77EB).

When I first installed the board, I got into the VisualBIOS and set some things (as we do).

Then I switched the onboard display to be Always Disabled and always use PCi-Express card (nVidia GTX 590).

I also set it to boot to UEFI, disabled legacy boot.

RapidStart and SafeBoot are disabled.

BIOS version is original (0320).

Next boot, 'No video' beeps.


Followed instructions for resetting BIOS ~ nothing.

Followed instructions for recovering BIOS ~ nothing.

Played with several different flash drives and their file systems for recovery ~ nothing.

After 4 days of trying everything, so far the best result has been with the following config:

- 8GB flash drive with 2GB partition formatted as FAT16.

- BIOS version 0324 .bio file on flash drive

- 1x 8GB RAM DDR3-1600 stick (that works)

- BIOS jumper removed (as per instructions)

- no PCi-E card, only on-board display


When I start the machine, I get to the BIOS splash screen, select F7, select the device, select the .bio file.

I press Enter, the system reboots and - - - nothing happens.

I have left it on for 30+ minutes in this state, and nothing.

It is in that state right now again, going on 74 minutes.

I have tried every conceivable method to reset the BIOS.



How do I recover or upgrade the BIOS so I can get into it again and use different settings?


It has now been 10 hours since posting this problem.

In the meantime, I have been able to get into the VisualBIOS:

- BIOS jumper removed

- no SATA devices connected

- 1x 8GB RAM

- no flash drive connected

- when splash screen (sometimes, about 1 in 4 tries) comes up, hit F2


Or not.

I change values, set everything to default or to Legacy, Save and Exit.

What happens?

Black screen.

Any ideas what to do?

If I can / should send it back to be replaced (again), please let me know on this forum post so I can tell my dealer Intel said so.

I don't think he'll believe a new board only lasted 1 day....

Update: 2015-08-06 17:31


It has now been a week since originally posting my problem, with not one answer from anyone, least of all Intel (at least 57 views).

Is there a way I can make someone read this and give me feedback?

I need to install this board back into a customer's box and give them a working PC.

A little help, please?

Update: 2015-08-18 11:57

It has now been 18 days since posting the problem, 21 days since experiencing it.

I am just going to send you back the board.

Just give me a new one.

Update: 2015-08-28 02:48

Still haven't received a new board, or even heard from dealer or Intel.

Also still no reply to this post.

Update: 2015-09-03 11:37

So on Monday I received a brand new board (again).

Thank you, Intel RMA (again).

So now...

I am trying to get the board to realize that I have a PCi Express card installed.

It is a Gigabyte nVidia GTX-590 that works on ANY OTHER BOARD I HAVE TRIED IT ON.

It works on an old IceDale (DG45ID), it works on an EB Lake (DH77EB), it works on an even older Raisin City (DG41RQ) ~ it works on anything with a PCI Express slot.

So why not on the Round Lake?

I have tried every combination of display settings (except 'Onboard always off' or else it might never stop beeping [again]).

I have tried these settings on nearly every version of the BIOS that there is (got the board on 0320, went through 0324, 0326 and now on 0330).

Whatever I tell it to do, the board ALWAYS boots to the onboard.

I have read the product brief, the technical spec and the user guide ~ nothing.

What must I do to get my board working?

The onboad is fine and well for typing letters and browsing the net, but for gaming...

Please, someone, just help, OK?

12 Replies

Please try the steps on Desktop Boards — BIOS Update Instructions



Dear Esteban

I have given up on Intel giving me the advice I need to get this board working.

I have now tried everything again with this second replacement board, but I just run smack into the same exact issues.

Please do not simply tell me to try the steps described on BIOS Update Instructions web page.

You would notice from my post(s) that I have already done everything Intel has suggested and many more.

My problem is STILL that I cannot get an nVidia GTX 590 to work on this board.

I have tried ALL the BIOS versions for this board, from 0314(!) to 0330, and nothing works.

Funny enough, I left the card in from my last attempt last night, and this morning I started the machine blind and installed the newest nVidia driver over remote desktop from another machine.

Before installing the newest driver, I disabled and then enabled the 590 (both instances) in the Device Manager, then installed the driver (nVidia GeForce 358.91 Win10 x64 WHQL).

The machine booted up with the 590 displaying properly!

I was really happy, so I checked everything and it seemed solid.

I then played a game for an hour, when the display flickered and came back, went black and came back, and then went black and stayed black,

It now does not use the 590 again.

The device manager shows Error 43 (dewvice not started due to an unspecified error), as before.

I have put the 590 into an old IceDale board and into an old DH77EB, and it works, so it is not the card.

Now I am getting quite tired of this board being advertised as working with my hardware and then not working with my hardware.

Some people have suggested that it is a UEFI thing, but no manner of UEFI setting makes any difference.

You will remember that my very first issue with this board was UEFI booting, which I have never attempted again as it does not work on this board.

Tell me how to get the board to use the nVidia GTX 590.

The BIOS does not listen to my settings, and no version of the BIOS firmware makes any difference.

The BIOS gives me the option of setting the nVidia as primary card, then uses the onboard only.

The BIOS picks up the card at Slot 6 running at 16x and 5.0GT/s.

The nVidia card is a Gigabyte GTX 590 (a GV-N590D5-3GD-B I believe).

The CPU is an Intel Core i5-4570 3,2GHz.

The memory is 2x 4GB DDR3-1600.

The Windows version is 10 Pro x64.

All other drivers are up to date.

Can you reproduce this error and fix my problem?


In that case the next course of action would be reinstall the OS using a validated OS from the list bellow, bear in mind that Intel stopped manufacturing this boards in 2013 therefore there are no drivers for windows 10 since by that time there was no Windows 10. Desktop Boards — Supported Operating Systems

Once you try with another OS and if by any chance you are still having issues. Please contact support at 916-377-7000.



Dear Esteban

The OS has nothing whatsoever to do with whether a board boots or does not boot.

The main issue occurs BEFORE OS LOAD, at POST time.

And I cannot afford to phone a support number in the US from Africa.

I will, however, in the spirit of detente and brotherly love, try Windows 7 or 8.

If I can find a clean, working hard drive. And time. And energy.

Also, new development:

I have been running the board on its integrated display for the whole day now, and a brand new issue has come up (3 times so far).

When the machine had been running for a while, it just halts (no response, not even Num Lock), the screen looks like a ZX Spectrum load screen, and the audio just produces high-pitched static, also much like a ZX Spectrum load screen (typical of a frozen hardware buffer).

1984 ZX Spectrum load screen: 2015 Intel DH87RL freeze screen:

After a hard reset the machine boots normally, and the event viewer shows nothing happening at the time of the freeze.

This means, most probably, that the fault is hardware related.


This is all happening on BIOS version 0330.

I will revert it to 0324 or 0326 (or something else stable); many people believe 0326 to be the only reliable BIOS for this board.

We will then see what happens.


If the machine then freezes again, I will remove the parts that do work (CPU and RAM) and go and buy an Asus board that will boot with my display card, and maybe even have working UEFI.

When that board proves stable, I will drive over the 87RL. With a combine harvester. Repeatedly.

And you can send me the money for the Asus board.


I will let you know what transpires with the 0324/0326 exercise.

Hello Kaptein_Superskoot:

Thank you for contacting Intel Communities.

I have some recommendations for you and some additional information also.

Regarding the issue with the PCIe slot not recognizing the GPU:

My recommendations would be:

*Check the "Primary video adaptor" setting in your BIOS: Advanced>Devices & peripherals>Video> Primary video adaptor is "auto" or "manually select the card"

*Check Integrated Graphics Device> Use Enable if Primary at BIOS level.

*In your bios, Check Integrated Graphics Device> Use Enable if Primary

*Test the system Disabling PCIe ASPM Support; this is under power at BIOS level.

Additionally, I would like to provide you with some information regarding the downgrade process for the BIOS.

Instructions for BIOS Version Downgrade

Make sure you are using the latest drivers from the manufacturer of your GPU, also another recommendation would be to test different drivers for your GPU, that may have an issue with your current components or OS.

Please provide me with the results for these steps and the steps performed by you.


Esteban C



*Test the system Disabling PCIe ASPM Support; this is under power at BIOS level.

I thought "No, really?"

Changing Power Management settings to get a display card to work?

And then ...

It seems ... to be working!

I will not mark this as the answer yet, for I shall be testing (read as: playing games) the rest of the day to make certain it does not go wrong again.

Thank you (with reservation until successful testing) for this insight.





That worked ... once...

It is back to only starting the onboard.

I will check the BIOS settings again, and make it Manual instead of Auto, but I have doubts.

Will let you know.


So that didn't work.

Back to being angry again.

System config:

Board: Intel DH87RL

CPU: Intel Core i5-4570 3,2GHz

RAM: 2x 4GB DDR3-1600 (Samsung M378B5273CH0-CK0)


PCiE card: NVIDIA GeForce GTX 590 (GV-N590D5-3GD-B)

BIOS: 0330

If you are able or willing to replicate my problem and give me a solution, fine.

Otherwise just leave it. I'm done.


Hello Kaptein_Superskoot:

Thank you for the results provided.

My recommendation would be to perform the following troubleshooting steps:

1. Test the GPU with a different video cable (HDMI, VGA, DVI). known to be working and high quality.

2. Test a different video interface.

3. Use a straight connection between the GPU and the display (Monitor, TV, etc.) meaning not using any adapters.

4. If doable, test the system with a different power supply.

5. Test the system with a different Graphics Card.

If the problem persists after performing the steps above, do not hesitate to contact Intel Customer Support to get warranty support with them, you can include this thread as troubleshooting reference. Contact Support


Esteban C


Hello, Esteban

Yes, I am still here, and yes I still have the same problem.

To answer your suggestions:

1. Test the GPU with a different video cable (HDMI √ , VGA √, DVI √ ). known to be working and high quality. ~ Done, all three

2. Test a different video interface. ~ Done, all four plugs on the card

3. Use a straight connection between the GPU and the display (Monitor, TV, etc.) meaning not using any adapters. ~ Done, originally no adapters

4. If doable, test the system with a different power supply. ~ Done, 500W, 750W, 1000W.

5. Test the system with a different Graphics Card. ~ Done, 4 different cards

Below is a comparison matrix for the different motherboards and display cards I used for my tests.

Note the ONE glaringly obvious problem:

Everything works on the 87RL, except the GTX 590.

The 590 works everywhere else but the DH87RL.

I have (just now) tried the last thing I can think of:

I plugged in an Apple Display Port to HDMI converter and then an Apple Display Port to HDMI converter, and I tried both on the GTX 590 in the DH87RL.

Result in both cases: FAILURE YET AGAIN.

All I get (on remote desktop session) is this:

So it seems your board has something against my display card specifically.

Any ideas?

Super User Retired Employee

It looks like the graphics card is having problems because the on-chip graphics is enabled. I would be setting the graphics mode to Auto, so that, (a) if no graphics card is plugged in, it enables on-chip graphics and uses it or (b) if a graphics card is plugged in, it disables on-chip graphics and uses the graphics card.



Dear Mr Pearson

In post # 8, you will see that the board was in Auto the whole time:

"I will check the BIOS settings again, and make it Manual instead of Auto, but I have doubts."

I have tried EVERY setting on the board, and from my test result matrix you can see I have tried all the hardware I have in nearly all the combinations mathematically possible.

It keeps starting with the onboard, or not at all.


I am done with this board now.

I have just taken it out and thrown it in the bin.

I will be getting an MSi or Asus later today, like I had to do for the client whose board this originally was.

In the meantime, I am running the 590 on an old EB Lake, with the PCIe ASPM Support ENABLED, and it runs fine, not one hiccup.

I am in fact typing this on that setup: the 590 on the EB Lake.

No fancy settings, basically BIOS defaults.


Ultimately the Round Lake turns out to have been a bad design.

Round Lake over and out...