Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
2,212 Views

DN2800MT renders BIOS settings read only

I configured BIOS and activated UEFI to boot debian testing. All worked as expected in the first place. I then played around with some BIOS parameters. Nothing special, all did function well.

In the course of further testing I changed my boot medium (used another USB stick). Unexpectedly as a net effect of all tampering now *no* BIOS parameters at all can be altered anymore. That means any change on any BIOS screen is not saved permanently.

The system still boots linux over UEFI without problems though.

When trying to change some BIOS parameter 'changed' in yellow letters appears in the bottom line as expected. But when confirming 'save & exit' it takes extraordinary long time until the screen changes to the next step. That's strange. All changes are discarded then. I notice that when entering the BIOS screen for the next time.

I had exactly the same symptoms with another DN2800MT but after playing around for hours it all of a sudden worked again. Unfortunately I can't reproduce what of my uncounted try and error attempts to recover the board was essential to heal it.

With my current (still defective) board I tried to downgrade BIOS from MT0155P.BIO -> MT0151P.BIO with no effect.

I tried to toggle BIOS Setup Configuration Jumper Block with no effect.

Don't know what else to try.

For me all this clearly seems to reveal a nasty BIOS bug.

Why can't I simply clear/erase everything to some safe default in BIOS?

I think an unconditional total reset of all BIOS parameters should always be possible with no dependency on the current state. Obviously BIOS developers for DN2800MT did simply forget to implement that.

I also tried to disconnect BIOS battery overnight with no effect. The BIOS does not forget it's current adjustements. Only some 'bios checksum error' messages show up on screen and event log.

Maybe somebody made some similar observations and knows any solution :-)

Thanks

sparkie

0 Kudos
14 Replies
idata
Community Manager
67 Views

Hello,

At this point what you can try is a BIOS recovery test.

The latest BIOS version can be downloaded from the following web site:

http://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=21349&ProdId=3382&lang=eng&OSVersion=...

Please be sure to read and follow all accompanying instructions, which can be found at this link:

http://developer.intel.com/support/motherboards/desktop/sb/CS-022312.htm http://developer.intel.com/support/motherboards/desktop/sb/CS-022312.htm

idata
Community Manager
67 Views

Thanks for the standardized answer. Sorry but it tells me nothing new. As already mentioned above (please read carefully) down- and upgrading the BIOS Version works but has NO effect on contents of BIOS settings. The settings are read only no matter what you do to the board. Even disconnecting the CMOS battery for days doesn't help.

In the meantime I found a solution. I created a new UEFI bootable USB stick from scratch exactly on the DN2800MT affected. Only with that boot medium connected to the board prior to power on it was possible to unlock BIOS parameters again. Booting with another otherwise working USB stick or even without any stick connected did not help.

I consider this as a BIOS bug that should be fixed in the future. I hope my error symptom description helps to do that.

idata
Community Manager
67 Views

Hello, sparkie!

Could you tell me the steps I need to take to create "a new UEFI bootable USB stick from scratch exactly on the MB affected", please? I've got exactly the same problem with my new D2700MUD board. All bios settings are stuck: I can change them in bios ui (though every simple change of a parameter halts ui for a couple of seconds, and so does "Save and Exit" option), after reboot they stay unchanged. And yes, UEFI Boot option is enabled.

idata
Community Manager
67 Views

Hiho,

Please please document your solution!

I have exactly the same Problem!

enaut

idata
Community Manager
67 Views

Hello,

I have the exact same issue. Unable to change any values in the bios except the date and the time. The error exists in the latest bios (159) also. I've tried to disconnect the battery for about 3 hours but the settings remained, and still can't change any value. Does anybody have any solution?

Intel!!!? Do you have any comment on this?

Peter

idata
Community Manager
67 Views

I didn't find any solution except updating the firmware (which renders the board broken - it stops even before activating the graphics hardware or firmware update routines) and send it in for a waranty treat.

idata
Community Manager
67 Views

My board survived the firmware update, but still behaves this silly way. I think I'm gonna return the board!!!!

Thanks for your answer.

Peter

idata
Community Manager
67 Views

This isn´t really a solution but rather a work-around to the problem.

If you know exactly which Bios settings you need to change, why not make a custom Bios Update with Intel Integrator Toolkit?

We use this tool to daily alter Bioses with custom splash screens and locked settings so that our end-customers can´t render the board unbootable (SATA IDE/ACHI/Raid settings and so on)

idata
Community Manager
67 Views

@noctem

I don't know if I really get you right. I have to stress though that I'm a simple user no Vendor or stuff. Meaning I bought a Board according to a list of features. However if I enable one of the feature I specifically wanted The board is rendered unusable. I consider that a bug in the firmware and honestly I think its Intels Job to fix this not mine. Even though I might be able to do this I think its not worth the effort to fix this issue just for my board.

And I am really frustrated that I can't find any place where I can post a ticket about that problem. I mean it reproducable and quite clear where to search for the error! But no Intel just repairs the board and sends it back without fixing the initial problem

Intel your support is great but your maintenance of your models and firmware sucks!

idata
Community Manager
67 Views

Hello,

as reported on this Intel document:

http://qdms.intel.com/dm/d.aspx/3C621435-090C-4E38-A54E-7B0E51612DC7/PCN111843-00.pdf http://qdms.intel.com/dm/d.aspx/3C621435-090C-4E38-A54E-7B0E51612DC7/PCN111843-00.pdf

seems that exist an bios for DN2800MT mb version 161 (two version newer of actual at downloadcenter)

but not yet maybe released to public.

Hope that fix all problems found until nowadays...and hope that be released soon...

idata
Community Manager
67 Views

Thanks for the info!

Actually I do not use that exact mainboard I just had the exact same symptoms. I created my own thread here:

The problem does not seem to be mainboard specific...

I think I will not install any OS in EFI mode since I already gave it for warranty exchange twice. I guess I can't do that infinitly oO...

Ok maybe I'll test it again if I see somewhere a fix note: "fixing problem when modifying EFI Bootmenu" or something similar. But until then or until some qualified Intel Developer asks for reproduction/testing help I'll just use it without EFI which is a pitty .

idata
Community Manager
67 Views

Hello,

I've returned the board to the supplier because I think it is defective. I agree with enaut, and I think it is a bug in the bios and Intel have to deal with it!

But thanks for your tip if I get back the board and still behaves like this I will try this toolkit.

Regards: Peter

idata
Community Manager
67 Views

Hello,

Intel released new bios version 161.

Try if resolve yours problem but I don't think, release notes not report nothing about.

My problem with tv tuner are still present.

idata
Community Manager
67 Views

Hello,

I have exactly the same problem, latest BIOS version (162) doesn't solve this issue.

Mainboard is completely useless with such a behaviour.

Will Intel plan to do something about it ?

Reply