Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Beginner
951 Views

DP55SB stuck at post with R9 280x

My pc wont boot anymore after updating nvidia gt 210 to R9 280X gpu. I have tried to downgrade and upgrade bios revisions but neither of those help, I started with the newest bios revision. Motherboards leds are showing E6 and on the post screen righ lower corner there is 5A. It is impossible to even acces bios when the R9 280X is connected. I am using i7 870 cpu and 2x4gb kinston ram. Does anyone have any idea what I can try to make this gpu work? Also it does not matter if my sata drive is connected or not.

0 Kudos
2 Replies
Highlighted
Super User
14 Views

I have seen a fair number of these where a PCIe 3.0 card claims to be backward compatible with 2.0 boards. It is an issue of not being fully backward compatible, where the card vendor has not fully tested such backward compatibility.

We know that there are some cards that work, and some that do not. Other than incompatibility, power supply problems, board failing, etc. could be the problem.

 

There are cases where board vendors will include support for only UEFI boot (and not Legacy boot, which most old systems are using).

There are also cases where the support for UEFI in the BIOS is not up to date with the version of UEFI supported in the Boot ROMs.

Your board is OLD, made long before your new graphics card. I have observed MANY of the AMD cards, such as yours, being a problem. Your support is not from here, but rather the manufacturer of the card. Remember, your GT 210 worked, and is a PCIe 2.0 card. Your board does not support PCIe 3.0, because PCIe 3.0 did not exist when your board was made.

By the way, your board is NINE years old. https://ark.intel.com/products/40079/Intel-Desktop-Board-DP55SB Intel® Desktop Board DP55SB Product Specifications A side note: Your board and CPU are not supported on Windows 10, if that is where you are going.

Doc

Doc (not an Intel employee or contractor)
0 Kudos
Highlighted
Beginner
14 Views

Thanks for fast reply. It really seems that the actual problem indeed lies with AMD. Since I tried my main rigs 980ti and it worked flawlessly. Going to get an Nvidia card to replace the R9 280x.

0 Kudos