Showing results for 
Search instead for 
Did you mean: 
Community Manager

DP67BG bios update procedure...

Hello all,

I got the DP67BG board a few months ago and recently I upgraded my system to have 16GB of RAM. As soon as I did this, the graphics started glitching out whenever I played any games, after much trial and error and reading, I finally came across the BIOS updates for it, versions 2111 and 2076. I was celebrating when I read the following on the list of fixes:

Version 2076

  • Fixed issue where some graphic cards cannot work with high memory.

Now the problem I'm running into is that I can't apply the BIOS update at all. I've tried all three available methods:

  1. Using the Windows BIOS update utility: It runs, reboots the system and loads back into Windows, then it tells me that the update was unsuccesful.
  2. Using the EZ BIOS update utility (hitting F7 during system startup): I find the file in the drive and it asks me if I want to proceed. I say yes and the system just reboots and nothing else happens.
  3. Finally, I tried using the IFLASH utility using a DOS bootable flash drive. I execute the command "iflash /pf BG2076C.BIO /rb" on the command line and the system just reboots immediately and nothing happens.

My guess is that when the system reboots, it's supposed to go into some sort of BIOS update mode where I can see the progress of the update being applied, I have formulated this guess from looking at screenshots and trying to find any information about this online. Regardless, it looks like I can't make the BIOS update at all. At this point I'm just looking for suggestions on what else to try.

I haven't tried clearing the BIOS using the jumper yet, so that might be something I can try. Also, I'm running BIOS version 2040, and when I first got the board (back in August), the board had an even older BIOS (I believe it was 1979), so at some point in the past I was able to flash the BIOS; I'm just unsure of why I can't now. Maybe I'm missing something.

Any help would be greatly appreciated!


0 Kudos
3 Replies
Honored Contributor I

Not sure if this will help your particular situation , It's a good pratice to do BIOS up-date off line with all security software turned off. I know for a fact Norton does this. it will interfer with the up-date.

Community Manager

it had nothing to do with security software, as I mentioned in my original post I was even trying to do it with a USB boot disk using the IFLASH2 command line utility, and it still didn't work.

However, I can now report that the BIOS is now updated. I'm not sure exactly what fixed it, but now I can run the BIOS updates.

To get it work I did two things:

  1. Set the BIOS configuration jumper to configuration mode.
  2. Boot up, enter the BIOS, load defaults and clear the BIOS password (I didn't have one to begin with but I figured what the hell)

After that, I tried using the IFLASH utility again and it finally worked.

Anyway, my guess is that the BIOS had to be cleared and had its settings set back to default before attempting to update it. Hopefully someone finds this useful.

Community Manager

I can report that I was having the exact same problem. I tried applying offline with all security software disabled, still no go.

Gave up for a week or so and then came back and tried again and it worked first time.

However, now I wish that it hadnt worked as I'm having a problem of a "reboot loop" on wake from sleep as others in the below thread have