Intel® Desktop Boards
Peer-to-peer support only
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
11360 Discussions

DQ87PG: ATA Password fail


I've just tried activating the ATA Password functionality in the BIOS of my DQ87PG Board. I'm using an Intel 520 SSD connected to SATA Port 0. BIOS is 0036 - which is the latest version.

When I set a Master HDD password or a User HDD Password, the BIOS asks me to enter the password twice (which I do). Then I click the submit button and nothing happens. The password still stays at "no set" in the GUI and saving BIOS settings doesn't help either. The HDD does stay unprotected no matter what I do.

Even if it were to work, the BIOS complains if I enter a password that is more than 8 characters long. Is this some kind of sick joke? Everyone knows that an 8 character password is not secure in these days against brute force attacks !!! I bought intels latest board in the most "professional" edition (Q87 chipset) and I'm still not allowed to set an ATA Password longer than 8 characters?

I'm really frustrated and would threaten to not buy Intel boards again, but that would be kind of a silly threat at this point, wouldn't it?

0 Kudos
1 Reply

I have done further tests in the last hours. The password can successfully be set if it is 7 characters or less. Even though it explicily mentions that the password must be 2-8 characters if a longer password is entered, an 8 characted password is SILENTLY IGNORED and nothing is set.

A shorter password works. My guess is that either only complete morons are left in Intels BIOS department or that Intel got a letter from the NSA telling them to make their crappy 8 char security even MORE crappy.

And please remember, this is all on a mainboard that is advertised by Intel as:

" Strengthen Security with Intel® Desktop Board DQ87PG"