Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
930 Views

DX58OG Can't UEFI-Boot Win8 Install Media

I'm using DX58OG with the latest version of the board BIOS (0888). It is a UEFI-capable BIOS, with UEFI Boot Option in the Boot menu. My primary hard drive (a brand new unused SSD) and the optical drive are plugged into ports 0 and 1 of the six black SATA ports (wired to the ICH10R southbridge), and the SATA controller is running in AHCI mode.

I'm not able to boot the Windows 8 Pro installation medium (DVD), with UEFI Boot enabled. The boot order set is "normal", and sequence is Optical Drives > Hard Drives. When I switch to "advanced" boot order and reboot, the two drives disappear from the list of drives to assign an advanced boot order from.

I want to take advantage of Windows 8 Secure Boot feature, and as such I want UEFI boot to work. I don't want to install the OS with legacy boot. What should I try next?

0 Kudos
2 Replies
idata
Community Manager
73 Views

Make sure all the fast boot stuff is turned off: general optimizations, usb, video.

Next hit F10 when it boots and select the windows 8 installer, it should show cd drive and uefi cd drive, select uefi cd drive. Also make sure uefi boot is enabled in BIOS

idata
Community Manager
73 Views

All boot optimizations were/are disabled.

With UEFI boot enabled, when I hit F10 during boot, I see the boot device selection list, but there are no drives in it, not even the optical drive. I've also tried a 5 second pre-boot HDD delay.

Reply