Intel® Desktop Boards
Peer-to-peer support only
11436 Discussions

DX58SO + GeForce 780 = Not working



It appears as though the DX58SO "Smackover" (and from reading these forums, many other intel mobos as well) has a bios incompatibility with the new 780. (Note: People appear to be having trouble with the Titan as well from reading around)

- The brand of 780 I have is EVGA, and is in the 3GB variant. (Other computer specs: 16GB RAM, i7 980)

- I tested the card in a slightly older ASUS motherboard, worked perfectly fine.

- I am running the latest BIOS for the DX58SO. I also previously tried a BIOS for it released in 2011.

- The computer shows the BIOS splash screen, but is unable to open F2 settings. In the bottom of the screen 5A shows, but I feel that is unrelated since it relates to SATA devices.

- I tried unplugging all SATA devices, no difference. Also tried all but the boot device, no difference.

- Tried many variations of supplying power to the card. All seem to work, as the card lights up and spins. The machine has plenty of juice to power this card.

- The DX58SO beeps twice over the course of about 60 seconds displaying the splash screen, then beeps twice quickly to show a black screen. After that, there no activity whatsoever (no HDD lights, etc) If I press keys, it will beep after a delay of about 5 seconds.

Is there any chance of this being fixed? My guess is that the UEFI vBIOS on the GPU isn't compatible for some reason with the DX58SO, even though it looks like it should be. I have contacted EVGA about the issue and it has been sent off to their product team as well.


0 Kudos
4 Replies


Even i have the same problem, but its with HD 7950!!

when i installed it my system, it didn't go beyond the splash screen. I thought the psu that am using was not enough (CX500), so got a bigger psu (GS700). Still the problem was the same.

Am using DX58SO mobo for almost 4 years and is working fine with my Sapphire HD 5770. So to further investigate i got my friends' very old MSI p7n platinum and it worked !! The graphic card accepted the mobo or should i say the mobo accepted the graphic card ?? this board too has 2XPCIE2.0 16x slots.

So, the problem seems to be my Intel DX58SO. Am stuck !! i've tried updating my bios (the last bios update for DX58SO - 5/2012), removing and installing new drivers.


I tried updating the bios on the 7950 too when i installed it in my friends computer, but it already has the latest one.

pls help me with this ! why did this work on a mobo which was a lot older than mine ? has intel stopped supporting its old motherboards ? if its bios related pls roll out a patch or a newer verson and do not suggest me to go for a different mobo as I cant afford to get a new one now.




My problem has been solved by a new BIOS update for the GPU provided by EVGA. The card now runs flawlessly.

Abhix58, if I were you I would post about the problem in the forums for your brand of graphics card. They will be much more helpful to you than Intel.

Best of luck,



Thanks Evan,

I have already mailed them all the necessary information. And my gfx card bios is already updated to their latest version. In the mean time i did find a way to get through the bios.

1. I plugged my old hd 5770 in the primary pci adapter (with hdmi cable attached) and the hd 7950 on the secondary adapter (no video out ).

2. Powered up the 7950 with the 8 and 6 pin cables , the 5770 with molex to 6 pin adapter.

3. Switched on my pc. Both cards started running as expected.

4. Bios worked as it chose my 5770 as its primary display adapter. Bios also showed my 7950 in the second slot.

5. Went inside windows. My catalyst controller showed both graphic cards in the hardware information. (Primary adapter:5770, Disabled adapter:7950) So no problems with the cards.!!

6. To check if my 7950 works properly, i unplugged the hdmi cable from 5770 and plugged it in 7950 while still operating in windows, and it worked !! Display worked fine, videos, games worked.

But still my problem wasn't over, i cant keep swapping hdmi cable from 5770 to 7950 every time i switch on my system. so,

7. I uninstalled all ATI drivers while still using 7950.

8. Restarted the system, with 5770 still attached. Now since the hdmi cable was plugged to the 7950 and 5770 still on the board, bios somewhat accepted both the cards and let me through to windows !!! the problem here is that [B]bios needs my 5770[/B] :-( and so it flew past bios and i landed directly onto the windows log in screen.

9. Went inside windows and installed the latest drivers.

10. Now my catalyst controller shows primary adapter as 7950 and disabled adapter as 5770.

To sum it up, I still need a latest bios update for my board, till that time i can keep using this AWESOME card. The 5770 is eating up extra power, i have to find a low performance, low power consumption old gen card to replace this. And to go inside bios i have to remove the 7950 !


For now the card is working just fine. But am still not sure if its the graphics card or the motherboard that needs compatibility upgrade. If in the near future i get another latest generation card and this problem persists, do i have to keep going to the card manufacturers ? when msi p7n platinum, a 2008 model mother board accepts this card which has bios version dated 2011, why cant this "smackover" board support too ??

Thanks !


The Smackover board is supposedly notorious for being a problem motherboard I've learned through this experience. I have five copies of this specific board - each of them behaved in an identical manner. In my case it was definitely the board, not the GPU. It seems to me like this is most likely true for your case as well.

This does not rule out the possibility for the issue to be fixed by a BIOS update on the GPU, however. Such was the case for me and my 780. Make noise about it on your GPU manufacturer's forum, that's what I did. It worked.

After contacting Intel support about a potential BIOS upgrade, I was told that they have no plans to upgrade it for the DX58SO, DX58SO2, DX68BC, or DX79SI.

I know that really blows for you having to deal with that inconvenience of having both cards on the motherboard sucking power, but to me it seems like your best option is to go the route of trying to get a GPU BIOS update rather than one provided by Intel to the DX58SO.

I'll also not be investing in Intel motherboards in the future from this experience and with Intel's support for this issue. (Although it's not their support team's fault for not being able to solve this, it's their engineering team or whatever team decides polices about EOL board support)