Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,299 Views

DX58SO - No HDD Found to BIOS failed to Devastation

Hi,

I have DX58SO which suddenly stopped recognizing my HDD.

So I decided to update BIOS which seemed like good answer.

So I tried F7, ISO but didn't work. So I went for BIOS Recovery.

Followed the steps, but when I plugged USB with .BIO file.

Nothing occured. No screen output either. Also, the USB was

not blinking either. I turned it off and went to try other USB and

CD. But nothing is being recognized for the BIOS recovery.

Now, I cant even get to the old bios. So when I turn on the

computer it just has black screen. No Keyboard or Mouse.

No booting. I'm thinking BIOS might have crashed.

Any idea of fixing this? How to make computer recognize

CD/USB for BIOS recovery? Anyone with similar problem?

Thanks in advance.

0 Kudos
3 Replies
idata
Community Manager
26 Views

Hi Eric,

Have you tried to unplugg the bios jumper as described in this manual (http://downloadmirror.intel.com/18128/eng/DX58SO_TechProdSpec.pdf http://downloadmirror.intel.com/18128/eng/DX58SO_TechProdSpec.pdf) page 53 -54 ? (Recovery Mode)

Be careful with USB Stick to format in FAT32. use a 2 or 4 GB usb stick to ensure compatibility.

Bios file located at http://downloadcenter.intel.com/Detail_Desc.aspx?DwnldID=21378 Download Center

idata
Community Manager
26 Views

Thanks for the reply,

Yes, I unplugged Jumper to be in Recovery Mode.

Yes, I used USB stick in FAT32 format with only .BIO file.

It seems to not work. The USB stick is not being read by the system.

When I have it connected and start the system. It only blinks once or twice.

Then no activity. Also, the screen does not show.

TGold1
New Contributor II
26 Views

Check your hdd in another PC to see if the hdd is the probem. I would add as a drive "D" to see if it works. I've had several Seagate drives fail due to broken cable mounting connectors. The connectors failed just sitting in the case. It seemed odd to me, but Seagate replaced the drives without question.

Also, follow the instructions on the link below to troubleshoot the BIOS:

http://www.intel.com/support/motherboards/desktop/sb/CS-028780.htm# noboot Desktop Boards — Troubleshooting BIOS issues

Good luck and best regards