Community
cancel
Showing results for 
Search instead for 
Did you mean: 
KMian
Beginner
1,613 Views

DX79TO loading EFI partition even before One-Time Boot Menu/BIOS Setup

Hello,

I'm having problems, whenever I have a GPT drive connected to any port. The BIOS seems to try to boot up the EFI partition (which right now should be a clean FAT32 partition) before loading Setup, if I press F2 (or even if I toggle the Back 2 BIOS button), but after showing all the standard POST information (VGA BIOS, POST Splash Screen - with the hotkeys BEING shown, RAID BIOS), also overriding any options I may have set for boot order, and giving me a pretty ugly "A bootable device has not been detected" prompt.

The only way I've managed to get to Setup or to a Boot Menu was by unplugging the GPT drive from the board, which renders me uncapable of doing any actual maintenance on the actual boot loader problem, even if I could boot Ubuntu from a LiveCD/USB or Windows Recovery Environment.

I had been running this system without a problem ever since I had assembled it, around one year ago. I have my drive setup as follows:

256GB SSD on Port 0

1TB SATA2 on Port 1

1TB SATA2 on Port 2 (in RAID 0 with the previous one)

1.5TB SATA3 on Port 3

DVD-RAM on Port 4

nothing on Port 5

After a long time running fine on only Windows in UEFI, I decided to install Ubuntu with it on the SSD. After many unsuccessful attempts to boot back to Windows (I was able to boot up Ubuntu), I tried to mess with the EFI files manually, as it seemed like GRUB had changed some of Windows' files there. All I did was append ".grb" to GRUB's "bootx64.efi" and rename "bkpbootx64.efi" under /EFI/Boot and /EFI/Microsoft, in order to see if I could restore Windows' original bootloader, in place of GRUB, and if this way it could boot back up, and then I couldn't even get to the BIOS setup before Windows Boot Loader shows up (and this still has the same problem as before). At this moment, if I tried "Startup Recovery", it showed up a "Windows is loading files..." progress bar, and then went back to the same boot loader screen. If I tried "Startup Windows Normally", it showed "Starting Windows" for a brief moment, then showed the same "Windows is loading files..." progress and finally, left me back at whatever screen I was BEFORE the Windows Boot Loader - if I came from GRUB, it would take me to GRUB again - I could repeat the process indefinitely without rebooting; strangely, if I came straight from the One-Time Boot Menu, it would also take me back to it, but this time without any Optical Drives listed.

After only getting success on reaching BIOS Setup by unplugging the SSD itself, I've took it out, reformatted the EFI partition, and now all I get is the doomed "A bootable device has not been detected", even if I have a bootable USB device, or a bootable CD - which are both set to boot before the Hard Drives.

The SSD is the only GPT drive, all the other ones I've maintained as MBR drives.

The system specs are:

Intel DX79TO Mainboard

Intel Core i7 3930K

Markvision 4GB DDR3-1600 in Quad Channel (16GB total)

NVIDIA GeForce GTX295 (on first PCI-E slot)

Corsair 750W PSU

Has anyone got any idea on what I could try?

Thanks in advance...

0 Kudos
6 Replies
Jose_H_Intel1
Employee
213 Views

Have you tried using a different BIOS version or hot plugging the SSD after booting from different media?

AEsta1
Novice
213 Views

i have the same issue, same motherboard. EFI partition loads even before b2b button or USB. tried with different bios'es

KMian
Beginner
213 Views

I kind of worked around the problem, but that's still not a solution: By unplugging the SSD, I was able to get back to BIOS Setup. From there, I tried resetting to factory defaults, which only worked until I enabled the UEFI Boot again. At least, I was able to boot from a Ubuntu USB key and from there backup my data and wipe the entire drive, which then 'solved' the problem.

I proceeded to install Windows 7 again in EFI mode, but it seems that for some reason, I'm unable to boot the newly-copied pre-install environment to finish the installation process. It keeps giving me "0x00000225 An unexpected error has occurred".

The only way I was able to install Windows 7 was by completely avoiding UEFI and using the old BIOS+MBR combo. I don't know if it really does make any difference in performance or boot time, but I noticed that my Windows Experience Index dropped from 7.6 to 7.3, when in MBR mode.

But now there are two questions shouting in my head:

Why did the BIOS get caught in this "EFI-deadlock", what exactly caused it?

And why, after apparently getting rid of (not exactly solving) the deadlock, I was (and still am) unable to install Windows 7 in EFI mode?

Even if I take all the caution to make the installer boot in EFI mode, load the RAID drivers, let Windows manage the partitioning for the fresh-wiped SSD and even after trying from different sources (original, SP1, Media Refresh - which was the one I used before -, both DVD and USB medias, using different methods/software to format/burn), it still ends up in the annoying '0x00000225' with Info "An unexpected error has occurred." boot screen.

AEsta1
Novice
213 Views

probably you didn't erased the EFI partition, and the old bootloader is still there. you can delete it using diskpart which is included in Windows 7 or 8 DVD.

KMian
Beginner
213 Views

Been there, done that. I couldn't even boot up Windows' PE before cleaning the SSD through diskpart in MBR mode - got stuck into the original boot 'deadlock' problem. I managed to get rid of this first problem by cleaning the SSD through DiskPart itself. The 0x00000225 error started appearing only after cleaning, building a new GPT and installing into a fresh unallocated heap (the entire wiped SSD, in case), and still kept appearing whenever I tried again, by wiping through GParted or DiskPart, cleaning, building an MBR, converting to GPT, cleaning again, building a GPT, or w/e and finally installing. The only way I was able to install Windows again was by getting rid of the whole UEFI stuff, disabling it and installing in MBR mode again, into a freshly partitioned MBR SSD making this not a solution, but instead jsut a duct-taped-workaround to the whole problem itself, which I can't seem to identify what is causing, nor where exactly it is happening, if it's in my SSD, in the MS EFI Bootloader, on Windows 7 itself, in the BIOS or whatever (maybe Ubuntu/grub messed up something on the UEFI/BIOS, I wouldn't be surprised considering this has happened once to me, unexplainably).

KMian
Beginner
213 Views

Alright, finally got my DreamSpark Premium subscription approved. I'll try to install Windows 8 Pro as soon as I get home from holidays and manage to download it - which will probably be around Monday evening. I don't intend to waste one of the finest improvements this board has over all my previous ones, and if Windows 8 manages to work without much hassle, maybe I can consider giving it a chance earlier than I planned.

Reply