Community
cancel
Showing results for 
Search instead for 
Did you mean: 
OSalz
Beginner
1,562 Views

DZ68BC refuses to recognize 32 GB RAM after CPU upgrade

I have a DZ68BC board with a 4x8 GB Corsair Vengeance 1600 Mhz memory kit. Until recently, I had that memory running at 1333 Mhz, because I had an i7 2600K, which is not capable of supporting 1600 Mhz RAM.

So, I just acquired an i7 3770, updated my BIOS and installed it, hoping that I could finally utilize the RAM fully at 1600Mhz. Sadly, the upgrade didn't go as smooth as I hoped and I ran into several reboot loops. I disconnected any hardware that wasn't crucial to booting and ended up downgrading the BIOS from 0042 to 0039. Then I could finally boot back into BIOS and saw the glorious picture of 32 GB of RAM at 1600 Mhz. So far, so good.

Then I connected all my hardware again, rebooted, and suddenly I was back to 16 GB of RAM. Now, no matter what I try, I can't get the BIOS to detect 32 GB of RAM.

I installed every module individually to make sure they aren't broke. The system will boot fine with every individual module, but, when I install all 4, the system will only show me 2 installed modules and 16 GB of RAM.

Tags (1)
0 Kudos
9 Replies
n_scott_pearson
Super User Retired Employee
87 Views

Gee, I have an i7-2600 DZ68ZV system running 16GB (4x4GB) memory at XMP1600. I am unsure where you got the idea that you couldn't (did you try?).

What is the full product Id for this memory? Is it on the list of tested RAM for this board?

...S

OSalz
Beginner
87 Views

Heh, no I never actually tried. The specs I found on the web said that the CPU only supports up to 1333 Mhz. I guess, it could have worked with 1600 Mhz as well, but I wanted an upgrade anyway and I didn't want to run the system over specs.

I didn't find the actual ID for the RAM, I'll try to read it with some hardware info tool when I'm back home. AFAIR, it's not on the list of tested RAM for this board.

n_scott_pearson
Super User Retired Employee
87 Views

The sticker on the side of the DIMMs themselves will provide you with the id...

OSalz
Beginner
87 Views

Good call! It's CMZ32GX3M4A1600C9

n_scott_pearson
Super User Retired Employee
87 Views

Unfortunately, even going to Corsair's site, I was unable to determine what organization these DIMMs use. The typical reason why only half of the memory is seen is because the DIMMs are organized x16. In these boards, in order to utilize two DIMMs per channel, the memory must be organized x8.

Hope this helps,

...Scott

OSalz
Beginner
87 Views

The thing is that I was using all 4 DIMMs just fine for months.

n_scott_pearson
Super User Retired Employee
87 Views

Hhmmm, what if you disconnect all of the additional hardware and test again?

Also, have you tried using the recovery method to upgrade to BIOS 42?

OSalz
Beginner
87 Views

Well, when I connected the hardware and was set back to 16 GB, the first thing I did was disconnect everything again, but it didn't make any difference. But I will try this again next week.

I didn't use the recovery method to update to 42, maybe that was a mistake. I used the F7 BIOS Update option during boot. I'll give 42 another chance next week as well. I'll report back

OSalz
Beginner
87 Views

Sorry for taking so long, but I just couldn't find a time to mess with this machine.

So, I've updated to 42 using the recovery method. This resulted in reboot loops. So I disconnected all power and removed the battery to force a full CMOS reset. Afterwards, the computer would not turn on. It would instantly turn off after I powered it on. So I just held down the power button and that got me a bit further. I got the usual notice regarding time not being set and whatnot, but I was still unable to get into BIOS. The computer would always reboot when I tried to enter setup.

I then removed all RAM except for the module closest to the CPU and was then able to enter BIOS (yay).

I put in another module in a bank colored the same as the bank closest to the CPU (black) and the system is back to rebooting when I try to enter BIOS. I try a different module in the same bank, same result.

Alright, so I assumed that this BIOS version just wont work out. I decided to downgrade to 35 via recovery method. Apparently that is the earliest version that supports my CPU. After the flash completed, I instantly removed the battery to force a full CMOS reset, before even attempting to power on.

At first, the machine wouldn't come up as usual. So I went back to 1 stick of RAM and it booted into BIOS. I then gracefully went up until all 4 sticks were installed, and I got into BIOS with 32 GB RAM (yay again). However, they're running at 1333 Mhz. This was right after a reset, I configured the performance section and set the memory to 1600 Mhz and rebooted...

And it worked \o/

So, I did so much, it's hard to tell what really made the difference now. But I won't touch anything again unless I absolutely have to.

Thanks a lot for your support!

Reply