Intel® Desktop Boards
Peer-to-peer support only
Announcements
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11451 Discussions

DZ68DB and 0040 bios update failed?

idata
Community Manager
1,355 Views

Hi, I have had the DZ68DB and enjoyed a stable system for about half a year. Then I installed some bios update (probably 0035) through Intel Integrator in Windows and started experiencing reboots once in a while, in the end daily. So I decided to try bios 0040 update and now the system powers on, but nothing is coming up on my monitor, not even with the bios jumper in configuration mode. I have tried both DVI and HDMI port. After reading this forum I found that there had been issues with the newest bios versions and that Flash Update Sleep Delay option should be enabled, which I think was enabled, but I can´t check since I can´t get into bios. I also read that DZ68DB has a issue with monitor giving power to the motherboard even, if power switch was off and cable unplugged.

My questions are:

1) Any advice how to try enable Flash Update Sleep Delay without the monitor?

2) Should I try to re-flash the bios in recovery mode?

3) How to identify if something is fried?

4) If my mobo is dead, how can I RMA this is Finland?

Thanks in advance, this is pretty awful!

0 Kudos
2 Replies
idata
Community Manager
164 Views

Just wanted to update this post. I got a new DZ68DB motherboard through warranty, the shop I got it from tested it and said the motherboard was dead. So, before installing windows I tried to update to 0042 (the mb had 0040) through F7 and thumbdrive procedure, but the update failed AGAIN! Something really wrong with this motherboards bios update mechanism. I had flash delay on and did everything according to instructions, but the system shutdown in the middle of the bios update. Took it to the shop again

idata
Community Manager
164 Views

This problem is occurred on my Intel DZ68DB. I had RMA and got the replace motherboard. I'd updated via "F7" again still failed again. Then RMA again try 3rd Intel DZ68DB, it's still failed.

Reply