Showing results for 
Search instead for 
Did you mean: 
Community Manager

DZ77BH-55K 085 BIOS update failure


Bought the DZ77BH-55K with i7-3770 processor to upgrade my Media Center PC. As I started the migration from DX48BT2 with Core2 Quad 9650 processor to new congfiguration the first I noticed is that the Hauppauge HVR-2200 PCI-E 1.0 tuner is not recognized by the motherboard while everything works just fine on Intel DX48BT2. A solution came after searching the forum in the post /thread/30706?start=0&tstart=0 which suggest the BIOS update is necessary.

I Downloaded the 085 bios from download page and loaded default BIOS parameters. I run the BIOS update program from the Win7 x64. After reboot the BIOS started update. However, as soon as the Main Firmware was flashed the computer turned off without any further sign of life. After about 10 minutes I turned it on. No boot, video configuration beeps comed from the system.

I shut down the system and switched to maintenance mode. I was being able to enter the BIOS but could do nothing to correct the improper BIOS flash. Tried to update the BIOS with the BIO file on USB key by hitting F7 button. BIOS never reponded to the pressed key.

As a last ressort I tried BIOS recovery. Nothing happend after entering recovery in the 15 minutes that followed.

Now what I have is the three beeps pause, three beeps pause, etc. at the start up with the POST code 14 on the indicator.

Moved the memory back to DX48BT2, memory is working flawlessly (4x 2GB DDR3).

Tried to call Intel Customer Support today. No joy, they do not respond at all.

What's next? Any advise or help is highly appreciated



Message was edited by: Michel Speranski&# 13; Just forgot to add that I also removed CMOS battery for entire night and tried to start up the computer the next day. Again three beeps pause, three beeps pause, etc.

3 Replies
Community Manager

remove all add in cards, hard drive, etc. run the system with only CPU and 1 stick of memory.

try to flash the bios, again.

Also try using a PS/2 keyboard and see if F7 works.

unplug any usb keyboards/mouse/etc.

Community Manager

Hello Shaun

Thank you very much for answering. I flashed the bios with only video card present on the board. Unfortunatelly, the system is not passing even the beging of POST sequence... When system powers on, it gives three beeps pause and the sequence repeats continuously with 14 indicated on the POST indicator. This happens whatever mode I choose: normal, maintenance, recovery. Also, nothing is displayed on the monitor at all.

Any suggestion?

Community Manager

Did you try with only one stick of memory?

I've had problems getting this MB to boot with all four memory slots filled. I would get the three beep memory error and the ONLY way I could get the computer to boot was to remove at least one stick of memory from the fourth slot from the processor.

I now have it working but cannot set the memory to 1600 as it should be or it will give the beeps.


EDIT - I just updated my bios from 083 to 085 and no problems so far