Intel® Desktop Boards
Peer-to-peer support only
11428 Discussions

DZ77BH-55K USB2 not working at all, but USB1 works fine

Community Manager

Hello everybody,

I recently acquired a brand new DZ77BH-55K motherboard currently running with the latest bios update (BHZ7710H.86A.0096.2012.1219.0921). It's powered by a high quality 650W Seasonic power supply, which is more than enough to run smoothly everything I have in my system.

The problem I've been encountering right from the start (at least ever since I did my first bios update few days after its setup) is that absolutely no USB port (either rear or front, USB3 or USB2) is able to make any of my USB2 peripherals work, while any USB1 peripheral (mouse, keyboard, several midi controllers, etc...) works perfectly. I didn't care much at the beginning since I only had an old 1 Gb flashdrive that could have been using USB2, but I recently acquired a quite expensive external soundcard which also happens to use USB2 and this made me realize that the problem seems much more serious than I thought (not just like the usual stuff that happens all the time with Windows and unrecognized flashdrives).

Even worse, the behavior of plugged USB2 devices is sometimes quite weird and scaring. Most of the time the device just seem to be stuck in a power ignition loop. The light from my USB stick keeps flashing eternally and my soundcard does pretty much the same (which is really not very reassuring considering its price). If you're lucky, sometimes it quickly stops and Windows pops an "Unrecognized Device" error up. I think this has a lot more chances to happen when you try this with a USB3 port.

Obviously, there's absolutely nothing wrong with these devices, as they're working perfectly on my laptop right off the bat. At first, I really thought it was something to do within Windows 7, so I did quite some struggling related to unrecognized USB devices, but after giving up and doing a fresh Windows 7 install, the problem was still there. So, while I was at it, I booted up a fresh Live-CD of Linux (puppy linux distribution) to be really sure. Plugged a USB1 flashdrive. Worked in any port. Tried with my USB2 flashdrive. Didn't work anywhere... So I am now quite sure that my USB ports are completely broken!

I also tried to fiddle with some settings in the bios (disabled legacy mode for USB, disabled most ports, etc...), disconnected front panel USB cables, removed all my PCI hardware, apart from my GTX 560 graphic card, etc... Everything with no luck.

So there you have it. I seriously hope someone will be able to help me, because I pretty much tried everything that I could do!

Thanks in advance,



Edit 1 : Oh yeah, Just in case, I also tried many time to unplug fully my computer and let it rest.

PS : here's more details about my setup.

====== Board ======

Manufacturer Intel Corporation

Product Name DZ77BH-55K

Version AAG39008-400

Serial Number BQBH220000UU

BIOS Version BHZ7710H.86A.0096.2012.1219.0921

BIOS ROM Size 8192 KB

BIOS Release Date 19/12/2012

====== Processor ======

Manufacturer Intel(R) Corporation

Processor Name Intel(R) Core(TM) i5-3450 CPU @ 3,10GHz

Processor Speed 3,1 GHz

Stepping 9

Form Factor Socket LGA1155

Hyper-Threading Technology Status Disabled/Unsupported

0 Kudos
4 Replies
Community Manager

I can't provide a solution to your situation, but I can offer that you are not alone. Since day one it seems to me that all of Intel's DZ77 boards have had issues with USB support in BIOS.

I have a DZ77GA-70K with the latest BIOS (0061) and with this version the USB keyboard or mouse, or a USB flash drive, are not recognized during POST when connected to one of the USB 2 ports, but work when connected to a USB 3 port. With some previous releases the same situation occurred, but the ports were different. So, for each BIOS release I have to play "find the port" to see which one I need to connect the mouse or keyboard in order to navigate and manage the BIOS setup.

I'm sure some of this is the result of this user not yet full understanding the fine points of running a 1st generation UEFI machine, I'm sure some of this is the result of Intel's evolving implementation of UEFI on their 1st generation consumer UEFI-compliant (?) desktop motherboards.

The only thing I can recommend is that you contact support directly (not doesn't read these except maybe the occasional bored intern) and have them open a ticket.

I have no proof that Intel has out-sourced out their BIOS maintenance and development, but from the behavior and the progression of fixes/issues I've seen it sure looks that way. The only way your issue is going to get visibility is if some Intel support engineer adds it to the list of issues for the contractor to investigate.

Community Manager

Hi there,

thanks for your answer! I think I'm just going to trash this board and stop wasting my time with it. I've also been having some ridiculous issues with the SATA ports (some just can't see my drives or end up freezing while in use, while I'm 100% sure it's not a problem related to any of my HDDs), which somehow disappeared after some random tweaking. Now that I've updated the Bios, they're also back...

Anyway, I bought an Intel board, while thinking naively that this would be the best choice for using a Intel processor... I couldn't have been more wrong! It's ridiculously far from Intel standards (I've never been disappointed with an Intel product) and not worth the price they're asking. it just looks like it's built like a 2nd-rate product and performs horrendously. The fact that they cannot nail something as basic as USB support even after a year of Bios updates pretty much says it all.



Community Manager

I certainly understand your frustration, and I sympathize to a large degree. I think, however, that the sort of apparently BIOS-related problems you, I and others experience with the 7-series chipset motherboards are not unique to the Intel-branded units.

I used to be a small-scale integrator and used a lot of Gigabyte and ASUS boards, in addition to Intel-branded products. If you check the user support forums for 7-series motherboards from those providers you will find a fair number of complaints similar to what we see here (the number of problems reported reflecting their much larger user base).

Same was/is true with their 6-series products, and everybody remembers what a mess the 5-series were for everybody when they first were released, and how long it took to get them settled down and (mostly) working.

For my part, I see Intel making steady (if slow and inconsistent) improvement with each successive BIOS release. Same is true, no doubt, with the other vendors, too, but I'm not sure if there is anything to be gained by switching at this particular time. We'll all know more in a couple of months.

In the meantime, I'm trying to verify if Intel still does BIOS maintenance in-house, or has outsourced that to a third party.


Since this board is no longer supported by Intel, the latest BIOS update was released back in 2013 Download BIOS Update [BHZ7710H.86A]