Intel® Desktop Boards
Peer-to-peer support only
11435 Discussions

DZ77GA-70K - Can't boot with RAID selected in BIOS

New Contributor I

Well I lost the RST set up after a failed F7 attempt to install BIOS 0063 ..... Arrg. Long Story

I had my system almost completely recovered to include the RAID-1 & SDD cache volumes, but when I was trying to change the mixed-up drive letters I obviously mistakenly selected in Drive Manager for the wrong volume. After the system failed to boot - I could tell what I did buy exploring Diskpart - my Win7 partition was no longer "C" The last drive letter I tried to change was now the "C" volume.

Original RAID-1 w/SDD RST config - SDD on SATA port 0 used to be Disk-0 and the two HDD on SATA 2 & 3 were Disk-1 with a System Reserve partition 100MB and then the "C" Win7 Boot partition 600GB.

After correcting active partition issue the only way I can boot with out a BootMGR missing error is with AHCI selected in the BIOS.

Also, when I select RAID will not access the RAID BIOS BOOT screen and after the last BOOT splash screen the text will display a BootMGR is missing.

Now I have two 2TB hard drives Disk-0 and Disk-1 - that are identical

My system is now Disk-0 has a System Reserve partition 100MB and then the "C" Win7 Boot partition.

Don't you just love the PnP!!!

I tried loading the RST driver with the drives in AHCI and rebooting - That was a bad idea because I had to recover from the BSOD during boot.

I tried to recover the RAID boot by selecting RAID and then loading the RAID driver in Windows repair utility but it did not work either.


So before I crash the Win7 install I though I would ask for some help.

Does someone have a procedure that can recover my system boot with RAID selected.


0 Kudos
1 Reply
New Contributor I

Things I am sure of:

1 - My system is possessed.

2 - To error is human

3 - To really foul things up takes a computer.

In order to re-estabilsh the Raid-1 and SDD cache, I re-installed BIOS 0061, rebooted and re-installed the RST driver in windows while drives were using the AHCI controller and then rebooted and selected RAID in the BIOS.

After that I had to run the boot rescue procedures 3 times (apparently the lucky number to solve the boot problem) and had to boot using Safe Mode to disable the last devices loaded that were causing BSOD.

Then before booting into windows CheckDisk ran and cleared a bunch of file errors.

So, between the checkdisk and the HP Printer software uninstall (printer process error) my Device Manager (devmgr.dll.mui) got hosed and I'm trying to find out how to recover the Device Manager. Running Sfc /scannow is how I discovered the corrupt devmgr.dll.mui file.

Lession Learned:

My system has a mind of its own!

Only do a BIOS upgrade with a full system backup in the bank!!