Community
cancel
Showing results for 
Search instead for 
Did you mean: 
NColl5
Beginner
1,542 Views

DZ77GA-70K doesnt boot with i7 3770

I just bought a new DZ77GA-70K motherboard to replace my broken gigabyte motherboard. I installed all my hardware into the DZ77GA-70K and when I powered it on, the motherboard gives me 3 beeps twice then shuts down and a LED code of 56. I then replaced the i7 3770 with an i5 3470 from a spare computer. After that the motherboard booted right up. I was wondering if the 3770 processor was dead or if the motherboard needs a bios update? The motherboard bios version is 39.

0 Kudos
7 Replies
NCook1
Novice
67 Views

What power supply are you using? Do you have the 8 pin ETS correctly in the motherboard? If so, if you're pushing the limits of a power supply it might be due to that. Also upgrading the bios is always a good idea if you can get the newest one installed with that 3470.

NColl5
Beginner
67 Views

Its the same hardware, all I replace was the motherboard, the motherboard I had before that broke was Gigabyte GA-Z77X-UD4H. The power supply I am using is Corsair 750w TX and I did plug in the correct 8 pin wire. Anything worked fine on that motherboard but the DZ77GA-70k wont boot with the 3770 but it will with the 3470. I looked up the TDP for both processors and they are both 77 watts. If a bios update is all I need to do, I'll do it.

NCook1
Novice
67 Views

I would certainly say that it's likely the bios then. I've not read through the patch notes myself but I would venture to say the bios is your best bet. Unless you're running Crossfired ATi cards you have more than enough power for anything.

EDIT: Just checked. 60 patch notes say they updated processor support. Likely why you're having your issue. Latest version is 63. Try it out!

NColl5
Beginner
67 Views

I'm currently running one 770 gtx for the video card. The one thing that worries me is that the 3770 came out in April of 2012 and the 3470 came out in June of 2012. The current bios I'm running on the board (39) was released in April 2012. So it makes me wonder why it would run the 3470 but not the 3770?

NColl5
Beginner
67 Views

I can conform that the 3770 is broken. I updated the bios to the latest version which is 66. Plugged in the 3770 and the motherboard gave me the same 3 beeps. I plugged back in the 3470 and the computer booted right up. I'm going to try and RMA the 3770 since its still under warranty.

NCook1
Novice
67 Views

That's really unfortunate! I hope it really is just the processor being bad, at least that way you know it has nothing to do with the board or anything. I've a 3770K myself. Have my own post going here. Takes a long time to boot.. but it works!

Kevin_M_Intel
Employee
67 Views

This motherboard supports the Intel® Core i7-3770 natively so It should not be necessary to update the BIOS unless you face an issue and a new BIOS update fix it.

The Intel® Core i5-3470 belongs to platform than the Intel® Core i7-3770 so if you tested the i5 processor and it is working I would say there is a problem with the processor.

You can also try with the BIOS updates but as I said, it should not be necessary.

Please contact our support center so they can help you gathering information about the processor and helping you with a replacement if necessary.

Here is our contact information:

http://www.intel.com/p/en_US/support/contactsupport http://www.intel.com/p/en_US/support/contactsupport

Kevin M

Reply