Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
950 Views

DZ77GA-70K freezes on F7

When I first built my PC I easily updated BIOS from 0046 to 0049 using F7 key and a thumb drive.

Now when I try to go into BIOS update (to try to install 0059) I get frozen on the skull screen.

I am wary of using express update via Windows as this seems more likely to cause bricking.

Help. Please.

William

0 Kudos
2 Replies
idata
Community Manager
42 Views

Couple of things to try before attempting to upgrade via the built in BIOS uploader:

enter into BIOS setup and reset all the options to default (F9), save and exit.

Make sure the thumb drive is formatted FAT16 or FAT32

Make sure that the .BIO file is the ONLY file on the thumb drive.

If an upgrade attempt hangs, power off and move the thumb drive to a different USB port. In particular, if the update fails with the drive in a USB 2.0 port, try again with the drive inserted into a USB 3.0 port.

idata
Community Manager
42 Views

Thanks these sounded like very logical suggestions but did not help.

The USB drive is FAT 32, and in fact the system hangs with our without it...I don't even see the screen where I can select the BIO file, just sticks at F2/F7/F10/Scary Skull screen.Boots fine if I go to F2 or F10 so it's not the keyboard.(anyway I tried another keyboard just to test the F7 key).

I tried all different USB ports, and also disconnected all other USB devices other than the Keyboard and mouse.

So I am still unable to flash the new BIOS but thanks for your help.

Any other ideas out there?

William

Reply