Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,712 Views

DZ77RE-75K Fan Control Problem

Hello! I have noticed that on my DZ77RE-75K motherboard that the fan control does not seem to be working.

In the BIOS I have set the control temperature to 65C and the max fan duty cycle to 100%. But when the CPU temperatures go above 65C there is no change in fan speeds.

Another thing I am having a problem with is that the Intel Desktop Utilities Program does not seem to be working. When I start the program, a spinning Icon appears indefinitely.

All this is with the latest BIOS revision: 66

And I reinstalled the Intel Desktop Utilities application after the update.

Thanks for the help!!

Tags (1)
0 Kudos
10 Replies
Highlighted
New Contributor I
5 Views

I have same problem fan control not work, dz77ga-70k + bios 64

0 Kudos
Highlighted
5 Views

Hello,

I'm going to try to replicate this issue. I will let you know.

Regards.

0 Kudos
Highlighted
Beginner
5 Views

OK, thank you! Let me know if you need any more info from me about the problem.

0 Kudos
Highlighted
Beginner
5 Views

Any updates? I have noticed that the CPU can get quiet hot without the fan control working properly.

0 Kudos
Highlighted
5 Views

Guys, I already reported this issue to the Engineering team. I am still waiting for an updated. I'll keep you posted.

 

Regards.

 

0 Kudos
Highlighted
New Contributor I
5 Views

May I know if Intel will fix this issue with a bios update or tutorial?

0 Kudos
Highlighted
Beginner
5 Views

Hey guys, since I never got a response from Intel, I started trying different things to fix the fan problem and I think I have found a way to fix it.

  1. Shut off the computer and unplug the PSU from the outlet.
  2. On the bottom right of the motherboard, a few inches above the yellow USB 2.0 port there should be a set of three pins with a small plug on the middle and bottom pins. Take the plug off the pins and put it on the upper and middle pin. Plug in the PSU cord.
  3. Now once you turn on the PC, it should be in maintenance mode. Go into the BIOS once the Intel splash screen appears.
  4. Once in the BIOS, press F9 to restore the BIOS to default settings.
  5. Now set up the BIOS settings the way you want them. Save and exit out of the BIOS and turn of the computer.
  6. Unplug the PSU and move the plug that you moved in step 2 to its original position(bottom and middle) . Plug in the PSU and boot up the system. It should be working fine now

These steps worked great for me, now the fans are working fine.

Good luck!

fishymamba, member of the linustechtips.com Intel Response Team

0 Kudos
Highlighted
5 Views

Thanks for the information, I will try these steps and check if they work on our system.

Regards.

0 Kudos
Highlighted
Employee
5 Views

It sounds like the BIOS configuration for fan speed control somehow got corrupted and restoring defaults fixed this corruption. This kind of corruption, in addition to affecting fan control, can cause Intel(R) Desktop Utilities (IDU) to get into this mode where the spinner appears seemingly forever.

If you get into this situation - and restoring defaults (and/or reinstalling IDU) - leaves the spinner spinning, send me a message. Attach to this message the following file:

on 32-bit Windows installs: "C:\Program Files\Intel\FSC\FSCAppServ.log"

on 64-bit Windows installs: "C:\Program Files (x86)\Intel\FSC\FSCAppServ.log"

...Scott

0 Kudos
Highlighted
New Contributor I
5 Views

I'm unable to save successfully options under the main menu>cooling tab the following options quiet/balanced/cool, basically the only one I can do is set minimum duty cicle under fan control, I'm still on 064 bios, all work perfectly but not colling options and control fan settings.

0 Kudos