Community
cancel
Showing results for 
Search instead for 
Did you mean: 
idata
Community Manager
1,311 Views

DZ77RE-75K ram question

Jump to solution

I have a DZ77RE-75K

I have left the default settings for the memory of which I am using CMP8GX3M4A1600C8

The bios is reporting that it is running @ 1333mhz

I have also downloaded a benchmarking tool 3DMark 11 Advanced Editionof which is reporting the RAM running @ 667 mhz

How can this be?

Any input would be greatful

0 Kudos
1 Solution
plee21
Valued Contributor I
61 Views

Hi

For compatibility 1600 memory will always report itself as 1333, you need to manually tell most motherboards it is something different.

If you enter the visual BIOS, find the memory settings and move the overclocking slider to 1600, save the settings and reboot, now you should be running at the memories rated speed of 1600.

Note that Intel Desktop utilities usually will still report the memory running at 1333, however if you download cpu-z, under the memory tab it will show frequency ~800Mhz, which * 2 (for double data rate) is 1600.

Regards

Phil

View solution in original post

1 Reply
plee21
Valued Contributor I
62 Views

Hi

For compatibility 1600 memory will always report itself as 1333, you need to manually tell most motherboards it is something different.

If you enter the visual BIOS, find the memory settings and move the overclocking slider to 1600, save the settings and reboot, now you should be running at the memories rated speed of 1600.

Note that Intel Desktop utilities usually will still report the memory running at 1333, however if you download cpu-z, under the memory tab it will show frequency ~800Mhz, which * 2 (for double data rate) is 1600.

Regards

Phil

View solution in original post

Reply