Showing results for 
Search instead for 
Did you mean: 
Community Manager

DZ77SL-50K boot problem after bios update attempt...


I have a DZ77SL-50K motherboard and tried to update the BIOS by using one of the four methods suggested. I choose the most commonly used and this is the file I've downloaded...


It's the latest revision for my motherboard. After I run the file... system booted but I didn't see anything on screen.

There's a blinking green led STDBY.

I removed tha CMOS battery to reset BIOS settings and followed the bios recovery procedure without success.

Is it a problem related to BIOS upgrading fail or a video problem?

No graphic card on my system. I'm using integrated HDMI graphics.


0 Kudos
1 Reply
Community Manager

Hello Tris,

According to the information provided the issue you are experiencing could be related to the BIOS update.

Here are our recommendations:

Test the system on a minimal configuration out of the chassis. Clear the CMOS battery for 30 minutes and test the system without memory looking for beep codes. Install minimum memory and proceed with a BIOS recovery test again as instructed here: Desktop Boards — BIOS update instructions

If the issue persists, replace the motherboard under warranty.

0 Kudos