Intel® Desktop Boards
Peer-to-peer support only
This community is designed for sharing of public information. Please do not share Intel or third-party confidential information here.
11462 Discussions

DZ77SL-50k audio driver problem


I built a custom gaming rig out of somewhat cheapish parts. Everything is working fine except the audio. No matter what I do, I can't seem to force the drivers to install correctly. Below is a list of everything I tried already and a complete list of the parts I've got plugged together. Any insight would be much appreciated.

Rosewell RISE ATX Full tower | with front panel audio

Intel DZ77SL-50K | no cards in any PCI/PCIE slot

2nd generation Intel Core i3 3.3GHz quad core processor | with integrated graphics | Socket 1155

1 4GB DDR3 module

Gamer's Edition 12V ATX power supply

Assorted mass storage devices in the USB ports | HDMI connection displaying video with the same driver problem for audio | LAN Broadband connection | External Apple optical drive (USB 2.0)

Windows 7 Professional x64

Problem drivers (the ones recommended by Intel): RealTek HD Audio driver | Intel Display Audio Driver

1. Windows installed with the front panel audio cable unplugged from the motherboard with the BIOS set to disable audio, so I went back and plugged it up properly and fixed the BIOS settings | BIOS updated

2. Any combination of uninstalling, disabling, reinstalling, clean installing, different version seeking, and automatic updating from every possible software distributor you can think of | Also asking Microsoft for drivers online through the native tool never completes. It just searches for drivers forever.

The problem is across the board, no audio devices detected though there are at least three audio sources connected to my motherboard counting display audio, all unable to properly install any driver. I'd be grateful if anyone's got an idea what might be causing the problem, and I know being a custom build makes the problem somewhat more complicated.

0 Kudos
2 Replies
Community Manager

Hello doctorpurple,



Thank you for joining the Intel communities.



Do you get any error in the device manager?



Try uninstalling the graphics driver and the audio driver and then reinstall only the graphics driver.


Uninstall these drivers from the device manger.



You can download the graphics driver for your system here:



Best wishes,





Community Manager




I'm just following on this thread to ask you if our recommendations solved your problem.



I look foward to hearing from you.